diff mbox series

[bug#38554,v2,3/3] gnu: python-hy: Update to 0.17.0.

Message ID f9ef700902ac6449be27d61f99cd9ed8ea2a7649.camel@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Jesse Gibbons Dec. 21, 2019, 5:14 p.m. UTC
* gnu/packages/python-xyz.scm (python-hy): Update to 0.17.0.
[inputs]: Add python-fastentrypoints, python-funcparserlib.
Fixes: https://lists.gnu.org/archive/html/bug-guix/2019-12/msg00034.html.
---
 gnu/packages/python-xyz.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

transforms

Comments

Brett Gilio Dec. 25, 2019, 7:27 a.m. UTC | #1
Hy Jesse! (ha).

Thank you for taking the time to do the revisions I suggested. I
actually could not apply your patches cleanly (not your fault). So I
went through and manually added and modified the patches as
necessary. You are listed as the author on all of the commits.

I tested the resultant Hy package, and it looks and works fine! I do
think eventually we should maybe consider moving Hy to its own file
though? With a name that is just "hy" and not "python-hy". Maybe a
discussion for a different day.

6b520177734e1c144fd6394f801919d0b54fa23e
c5eb8cf844148fb99934c3fedc3b4a0da55f9d8e
c215051dcf30b11c755aea4e2527b4d3d91c34bb

Thanks! Closing.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 906bd9c8d2..c5dc022475 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8514,20 +8514,20 @@  with a new public API, and RPython support.")
 (define-public python-hy
   (package
     (name "python-hy")
-    (version "0.13.0")
+    (version "0.17.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "hy" version))
               (sha256
                (base32
-                "19sfymaksx9jhksfnb15ahid46mzrhdfzz6yy2craz2qnzvpmky8"))))
+                "1gdbqsirsdxj320wnp7my5awzs1kfs6m4fqmkzbd1zd47qzj0zfi"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-	 (add-before 'install 'set-HOME
-	   (lambda _
-	     (setenv "HOME" "/tmp")))
+         (add-before 'install 'set-HOME
+           (lambda _
+             (setenv "HOME" "/tmp")))
          (replace 'check
            (lambda _
              ;; Tests require write access to HOME.
@@ -8539,8 +8539,10 @@  with a new public API, and RPython support.")
     (propagated-inputs
      `(("python-astor" ,python-astor)
        ("python-clint" ,python-clint)
-       ("python-rply" ,python-rply)))
-    (home-page "http://hylang.org/")
+       ("python-rply" ,python-rply)
+       ("python-fastentrypoints" ,python-fastentrypoints)
+       ("python-funcparserlib" ,python-funcparserlib)))
+    (home-page "http://docs.hylang.org/")
     (synopsis "Lisp frontend to Python")
     (description
      "Hy is a dialect of Lisp that's embedded in Python.  Since Hy