diff mbox series

[bug#70635] gnu: Add hexahop.

Message ID f9d9b72c45a3e0c993b4c45e2ab7f520d7d54b95.1714338636.git.sl@eauchat.org
State New
Headers show
Series [bug#70635] gnu: Add hexahop. | expand

Commit Message

Sébastien Lerique April 28, 2024, 9:10 p.m. UTC
* gnu/packages/games.scm (hexahop): New variable.

Change-Id: Id7a998d18c391af8d9722d2e637988ca019db304
---
 gnu/packages/games.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 4178eaf3b2eeea8f6c2e49b1d65cd60a1663c4a9

Comments

宋文武 April 29, 2024, 12:46 a.m. UTC | #1
Sébastien Lerique <sl@eauchat.org> writes:

> * gnu/packages/games.scm (hexahop): New variable.
>
> Change-Id: Id7a998d18c391af8d9722d2e637988ca019db304

Pushed to master as commit f1bcbdbde7, with changes:
- Use "mirror://sourceforge" for uri.
- Use "--with-sdl-prefix".

Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 57e6c23f41..8646b195f6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -81,6 +81,7 @@ 
 ;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;; Copyright © 2024 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2024 Sébastien Lerique <sl@eauchat.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -241,6 +242,41 @@  (define-module (gnu packages games)
   #:use-module ((srfi srfi-1) #:hide (zip))
   #:use-module (srfi srfi-26))
 
+(define-public hexahop
+  (package
+    (name "hexahop")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       ;; FIXME: the "mirror://" url leads to
+       ;;   https://web.archive.org/web/.../https://sourceforge.net/create/
+       ;;   instead of .../hexahop/1.1.0/hex-a-hop-1.1.0.tar.gz or similar.
+       (uri (string-append "https://download.sourceforge.net/project/hexahop/"
+                           version "/hex-a-hop-" version ".tar.gz"))
+       (sha256
+        (base32 "1mm069wpwc8nrrzfn2f64vh550634xlfws64bfmhqhx86vcikgw0"))))
+    (build-system gnu-build-system)
+   (arguments
+    '(#:phases
+      (modify-phases %standard-phases
+        (add-after 'set-paths 'set-sdl'paths
+          (lambda* (#:key inputs #:allow-other-keys)
+            (setenv "CPATH"
+                    (string-append
+                     (search-input-directory inputs "/include/SDL")
+                     ":" (or (getenv "CPATH") ""))))))))
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list (sdl-union (list sdl sdl-mixer sdl-ttf))))
+    (home-page "https://sourceforge.net/projects/hexahop/")
+    (synopsis "Puzzle game navigating paths over hexagons")
+    (description
+     "Hex-a-hop is a puzzle game in which a girl has to destroy green hexagons
+by stepping on them.")
+    (license license:gpl2+)))
+
 (define-public abe
   (package
     (name "abe")