diff mbox series

[bug#58315] gnu: nginx: Support SSL / TLS for stream proxies.

Message ID f9d3707a7c918c5fe4a00a089f287310955adbf4.1665001590.git.leo@famulari.name
State Accepted
Headers show
Series [bug#58315] gnu: nginx: Support SSL / TLS for stream proxies. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Oct. 5, 2022, 8:26 p.m. UTC
* gnu/packages/web.scm (nginx)[arguments]: Add "--with-stream_ssl_module"
to #:configure-flags.
---
 gnu/packages/web.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Oct. 14, 2022, 10:28 p.m. UTC | #1
Hi Leo,

Leo Famulari <leo@famulari.name> skribis:

> * gnu/packages/web.scm (nginx)[arguments]: Add "--with-stream_ssl_module"
> to #:configure-flags.

LGTM, thanks!

Ludo’.
Leo Famulari Oct. 17, 2022, 9:23 p.m. UTC | #2
On Sat, Oct 15, 2022 at 12:28:15AM +0200, Ludovic Courtès wrote:
> Hi Leo,
> 
> Leo Famulari <leo@famulari.name> skribis:
> 
> > * gnu/packages/web.scm (nginx)[arguments]: Add "--with-stream_ssl_module"
> > to #:configure-flags.
> 
> LGTM, thanks!

Thanks, pushed as d85c254319435c3fcd1fc5842769b9f167f92b14
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3262dbbb10..a96e9456ad 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -407,6 +407,7 @@  (define-public nginx
               "--with-pcre-jit"
               "--with-debug"
               "--with-stream"
+              "--with-stream_ssl_module"
               ;; Even when not cross-building, we pass the
               ;; --crossbuild option to avoid customizing for the
               ;; kernel version on the build machine.