diff mbox series

[bug#68262] gnu: Add r-escape.

Message ID f9d2575df3bdaa100e0fea7ff294a14961008003.1704458386.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#68262] gnu: Add r-escape. | expand

Commit Message

nafkhamdc Jan. 5, 2024, 12:39 p.m. UTC
* gnu/packages/bioconductor.scm (r-escape): New variable.

Change-Id: Ia308f9c90fa81c3304f97daa4f56ae4cd722d5cc
---
 gnu/packages/bioconductor.scm | 39 +++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)


base-commit: ac69b423865f12310cef5662d9c303aa4b90c869

Comments

Ricardo Wurmus Jan. 10, 2024, 5:49 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bf38afb762..caee2842a7 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1127,6 +1127,45 @@  (define-public r-ensdb-mmusculus-v79
 Ensembl.")
     (license license:artistic2.0)))
 
+(define-public r-escape
+  (package
+    (name "r-escape")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "escape" version))
+       (sha256
+        (base32 "0bmin69ax7l5x3a0k9mv183277a0hl4znx02y79v2ilkgqkdm7fn"))))
+    (properties `((upstream-name . "escape")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocparallel
+                             r-broom
+                             r-data-table
+                             r-dplyr
+                             r-ggplot2
+                             r-ggridges
+                             r-gseabase
+                             r-gsva
+                             r-matrix
+                             r-matrixgenerics
+                             r-msigdbr
+                             r-patchwork
+                             r-reshape2
+                             r-rlang
+                             r-singlecellexperiment
+                             r-stringr
+                             r-summarizedexperiment
+                             r-ucell))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/escape")
+    (synopsis "Single cell analysis platform for enrichment")
+    (description
+     "R-escape streamlines gene set enrichment analysis for single-cell RNA sequencing.
+Using raw count information, Seurat objects, or @code{SingleCellExperiment} format,
+users can perform and visualize GSEA across individual cells.")
+    (license license:gpl2)))
+
 (define-public r-snplocs-hsapiens-dbsnp144-grch37
   (package
     (name "r-snplocs-hsapiens-dbsnp144-grch37")