[bug#75032,01/13] gnu: Add sagemath-data-conway-polynomials.

Message ID f9a1601770443c87357b859e6d3a37f6d614974b.1734887844.git.monego@posteo.net
State New
Headers
Series Add more SageMath packages |

Commit Message

Vinicius Monego Dec. 22, 2024, 5:26 p.m. UTC
  * gnu/packages/sagemath.scm (sagemath-data-conway-polynomials): New variable.

Change-Id: Ia3a087b19a0ade5d927422bd365283d209df0863
---
 gnu/packages/sagemath.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 008f54a5e7..734aabf739 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -381,3 +381,24 @@  (define-public zn-poly
 coefficients of which are modular integers.")
     (license (list license:gpl2 license:gpl3)) ; dual licensed
     (home-page "https://gitlab.com/sagemath/zn_poly")))
+
+(define-public sagemath-data-conway-polynomials
+  (package
+    (name "sagemath-data-conway-polynomials")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "conway_polynomials" version))
+       (sha256
+        (base32 "1wz03a08kwlswx1pcr5d99ppmhpfzs2a5i969rnb2ghsz1j9yqag"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (home-page "https://github.com/sagemath/conway-polynomials")
+    (synopsis "Python interface to Frank Lübeck's Conway polynomial database")
+    (description "This package provides a Python interface to Frank Lübeck's
+Conway polynomial database.  These are used in several computer algebra
+systems such as GAP and SageMath to provide quick access to those Conway
+polynomials.  The aim of this package is to make them available through a
+generic Python interface.")
+    (license license:gpl3+)))