diff mbox series

[bug#65652] gnu: Add r-consort.

Message ID f99478103e05500d7a431a6746264473f59bd18f.1693471330.git.mail@sebastiangibb.de
State New
Headers show
Series [bug#65652] gnu: Add r-consort. | expand

Commit Message

Sebastian Gibb Aug. 31, 2023, 8:42 a.m. UTC
* gnu/packages/consort.scm (r-consort): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: d6966b8a5b4f2ddda2bc685b9642e7a1c2cbe17c

Comments

Christopher Baines Oct. 30, 2023, 11:30 a.m. UTC | #1
Sebastian Gibb via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/consort.scm (r-consort): New variable.
> ---
>  gnu/packages/cran.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)

Thanks for the patch, this looks good to me :) I've pushed it to master
as 549d7ce3b3ea502e5bc7be6f66f886b6ee81f9e8.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ec6b802ff..cccf02026e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -343,6 +343,29 @@  (define-public r-chromomap
     (license (list license:gpl3
                    license:isc)))) ;for bundled d3js
 
+(define-public r-consort
+  (package
+    (name "r-consort")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "consort" version))
+              (sha256
+               (base32
+                "1jshk53121w58i4if593qzxm6lcrrggz8parwhqvv6hnbx51rhck"))))
+    (properties `((upstream-name . "consort")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/adayim/consort/")
+    (synopsis "Create Consort Diagram")
+    (description
+     "To make it easy to create CONSORT diagrams for the transparent reporting of
+participant allocation in randomized, controlled clinical trials.  This is done
+by creating a standardized disposition data, and using this data as the source
+for the creation a standard CONSORT diagram.  Human effort by supplying text
+labels on the node can also be achieved.")
+    (license license:expat)))
+
 (define-public r-collections
   (package
     (name "r-collections")