diff mbox series

[bug#65201] gnu: Add r-partr2.

Message ID f97d9250e7fb89e17bf830d12ea2e356a2438d8b.1691663315.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65201] gnu: Add r-partr2. | expand

Commit Message

nafkhamdc Aug. 10, 2023, 10:28 a.m. UTC
* gnu/packages/bioinformatics.scm (r-partr2): New variable.
---
 gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 997b38badaee20a1c60411e5e599e260e47785ec

Comments

Ricardo Wurmus Aug. 10, 2023, 10:32 p.m. UTC | #1
Thanks for the patch.  I relocated the package to cran.scm and adjusted
the description.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b847c9a5d7..29f5403702 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -947,6 +947,34 @@  (define-public r-numbat
 solely on the donor scRNA-data data (for example, 10x Cell Ranger output).")
       (license license:expat))))
 
+(define-public r-partr2
+  (package
+    (name "r-partr2")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "partR2" version))
+              (sha256
+               (base32
+                "06ky0hhrq0mcsn9rwrzvwn0rrjj0l8rxs0hqp10668gdq5hjk8bn"))))
+    (properties `((upstream-name . "partR2")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-dplyr
+                             r-ggplot2
+                             r-lme4
+                             r-magrittr
+                             r-pbapply
+                             r-purrr
+                             r-rlang
+                             r-tibble
+                             r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/mastoffel/partR2")
+    (synopsis "Partitioning R2 in GLMMs")
+    (description
+     "An R tool for estimating and partitioning R2 in GLMMs based on predictor variance.")
+    (license license:gpl2+)))
+
 (define-public r-p2data
   (let ((commit "7d4c0e17d7899f9d9b08ab2bf455abe150912f4c")
         (revision "1"))