diff mbox series

[bug#64801,1/2] gnu: Add python-liana-py.

Message ID f9425fb2ae20749a606fbde79e278fd9f643767e.1690108906.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#64801,1/2] gnu: Add python-liana-py. | expand

Commit Message

nafkhamdc July 23, 2023, 10:41 a.m. UTC
* gnu/packages/bioinformatics.scm (python-liana-py): New variable.
---
 gnu/packages/bioinformatics.scm | 58 +++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)


base-commit: 445a0359083388b5ee686e6e855f94a3aac5f79c

Comments

Ricardo Wurmus July 31, 2023, 10:22 a.m. UTC | #1
Thank you for the patch!  I pushed it with minor adjustments.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 864c200707..a0ae298a2c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1863,6 +1863,64 @@  (define-public python-htsget
 servers supporting the protocol.")
    (license license:asl2.0)))
 
+(define-public python-liana-py
+  (package
+    (name "python-liana-py")
+    (version "0.1.9")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/saezlab/liana-py")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00lqrmi38wmdpjlcafgmrnkwsbp0yvm2rya6qs8y6jfizww9ff8i"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags '(list "-k"
+                               ;; These tests require internet access.
+                               (string-append "not test_generate_lr_resource"
+                                " and not test_generate_nondefault_lr_resource"))
+           #:phases '(modify-phases %standard-phases
+                       (add-before 'check 'set-home
+                         ;; Some tests require home directory to be set.
+                         (lambda _
+                           (setenv "HOME" "/tmp")))
+                       ;; Numba needs a writable directory to cache functions.
+                       (add-before 'build 'set-numba-cache-dir
+                         (lambda _
+                           (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+    (propagated-inputs (list python-anndata
+                             python-black
+                             python-cell2cell
+                             python-decoupler-py
+                             python-hypothesis
+                             python-ipykernel
+                             python-ipython
+                             python-mofax
+                             python-mudata
+                             python-nbconvert
+                             python-nbsphinx
+                             python-numpydoc
+                             python-omnipath
+                             python-pandas
+                             python-plotnine
+                             python-pypandoc
+                             python-scipy
+                             python-requests
+                             python-scanpy
+                             python-statsmodels
+                             python-tqdm
+                             tzdata))
+    (native-inputs (list python-pytest python-pytest-cov python-numpy))
+    (home-page "https://github.com/saezlab/liana-py")
+    (synopsis "LIANA is a ligand-receptor analysis framework")
+    (description "This is a Ligand-Receptor inference framework.
+The framework enables the use of any LR method
+with any resources.")
+    (license license:gpl3+)))
+
 (define-public python-logomaker
   (package
     (name "python-logomaker")