diff mbox series

[bug#39739] Here is the patch updated

Message ID f8f2deed5cfdf993d1808df4a2842fadd494f768.camel@korwin-zmijowski.fr
State Accepted
Headers show
Series [bug#39739] Here is the patch updated | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jeremy Korwin-Zmijowski March 18, 2020, 11:22 p.m. UTC
Freely yours,

Jérémy

Comments

Kyle Meyer March 19, 2020, 2:39 a.m. UTC | #1
Hi Jérémy,

Thanks for the update and for clarifying the license with the author.

Jeremy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr> writes:

> +;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>

This has a trivial conflict with master (4a0399e277 at the time I
applied it for testing).  That'd be easy for whoever eventually commits
your patch to clean up, but, if you resend the patch for the other
reasons I mention below, it'd be good to resolve it on your end by
moving that to a newer base.

> +(define-public emacs-ac-geiser
> +  (package
> +    (name "emacs-ac-geiser")
> +    (version "0.1")
> +    (source
> +     (origin

You should specify a `file-name' so that the directory in the store
contains the package name.  Note that you can run `guix lint' to catch
issues like these:

  $ pre-inst-env guix lint emacs-ac-geiser
  gnu/packages/emacs-xyz.scm:21842:5: emacs-ac-geiser@0.1: the source
  file name should contain the package name

> +       (uri (git-reference
> +             (url "https://github.com/xiaohanyu/ac-geiser.git")
> +             (commit "502d18a8a0bd4b5fdd495a99299ba2a632c5cd9a")))

This commit is a couple of commits after the v0.1 tag, so you can
represent that with something like

  (let ((commit "abcdef...")
        (revision "0"))
    (package
      ...
      (version (git-version "0.1" revision commit))
      (source
       (origin
         (uri (git-reference
               (url "https://github.com/xiaohanyu/ac-geiser.git")
               (commit "abcdef...")))

You can find a good number of examples in emacs-xyz.scm.

Because the author clarified the license in the next commit
(93818c936ee7e2f1ba1b315578bde363a7d43d05), I think that'd be a good
commit to use.

> +       (method git-fetch)
> +       (sha256 (base32 "0h2kakb4f5hgzf5l2kpqngalcmc4402lkg1pvs88c8z4rqp2vfvz"))))

Formatting/consistency nit: Most packages put "(base32 ..." on a new
line.  I think the same is true, to a lesser extent, for the value of
propagated-inputs below.

> +    (build-system emacs-build-system)
> +    (propagated-inputs `(("geiser" ,emacs-geiser)
> +                         ("auto-complete" ,emacs-auto-complete)))
> +    (synopsis "Auto-complete backend for geiser")
> +    (description "Provides one auto-complete source for Scheme projects using geiser.")
> +    (license license:bsd-3)
> +    (home-page "https://github.com/xiaohanyu/ac-geiser")))

Thanks!
diff mbox series

Patch

From 38eb230416cc43506fd3cdbf8cc3d1d7f08803c3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Korwin-Zmijowski?=
 <jeremy@korwin-zmijowski.fr>
Date: Wed, 18 Mar 2020 02:24:06 +0100
Subject: [PATCH 1/1] gnu: Add emacs-ac-geiser.

* gnu/packages/emacs-xyz.scm (emacs-ac-geiser): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a821bc7776..f691cd2fdf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -63,6 +63,7 @@ 
 ;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21807,3 +21808,22 @@  All entries in a specified TODO state will be carried over to the next day.")
        "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
 conversion program}, a Japanese input method on Emacs.")
       (license license:gpl2+))))
+
+(define-public emacs-ac-geiser
+  (package
+    (name "emacs-ac-geiser")
+    (version "0.1")
+    (source
+     (origin
+       (uri (git-reference
+             (url "https://github.com/xiaohanyu/ac-geiser.git")
+             (commit "502d18a8a0bd4b5fdd495a99299ba2a632c5cd9a")))
+       (method git-fetch)
+       (sha256 (base32 "0h2kakb4f5hgzf5l2kpqngalcmc4402lkg1pvs88c8z4rqp2vfvz"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("geiser" ,emacs-geiser)
+                         ("auto-complete" ,emacs-auto-complete)))
+    (synopsis "Auto-complete backend for geiser")
+    (description "Provides one auto-complete source for Scheme projects using geiser.")
+    (license license:bsd-3)
+    (home-page "https://github.com/xiaohanyu/ac-geiser")))
-- 
2.25.1