diff mbox series

[bug#70552] gnu: Add iwgtk.

Message ID f8e832c998d1422863037f88fea360cb8d8b2ec3.1713974969.git.jsubuntuxp@disroot.org
State New
Headers show
Series [bug#70552] gnu: Add iwgtk. | expand

Commit Message

James Smith April 24, 2024, 4:09 p.m. UTC
* gnu/packages/networking.scm (iwgtk): New variable.

Change-Id: I8dc5446fda114f033c1e594028668af41cd5ec85
---
 gnu/packages/networking.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 91d9e145e15241c20729a4f1fa43f3d662f6b806

Comments

Z572 April 30, 2024, 3 p.m. UTC | #1
James Smith via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/networking.scm (iwgtk): New variable.
>
> Change-Id: I8dc5446fda114f033c1e594028668af41cd5ec85
> ---
>  gnu/packages/networking.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 9d657bc69d..dbc6280416 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -64,6 +64,7 @@
>  ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
>  ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
>  ;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
> +;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -99,6 +100,7 @@ (define-module (gnu packages networking)
>    #:use-module (gnu packages)
>    #:use-module (gnu packages admin)
>    #:use-module (gnu packages adns)
> +  #:use-module (gnu packages aidc)
>    #:use-module (gnu packages algebra)
>    #:use-module (gnu packages audio)
>    #:use-module (gnu packages autogen)
> @@ -144,6 +146,7 @@ (define-module (gnu packages networking)
>    #:use-module (gnu packages linux)
>    #:use-module (gnu packages lua)
>    #:use-module (gnu packages kerberos)
> +  #:use-module (gnu packages man)
>    #:use-module (gnu packages mpi)
>    #:use-module (gnu packages ncurses)
>    #:use-module (gnu packages nettle)
> @@ -4152,6 +4155,30 @@ (define-public iwd
>  maximum extent possible.")
>      (license license:lgpl2.1+)))
>  
> +(define-public iwgtk
> +  (package
> +    (name "iwgtk")
> +    (version "0.9")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference (url "https://github.com/J-Lentz/iwgtk")
> +                           (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1fvxq4ydhzisfn93pcqbspqqi8fwj45v8q104bkm4qfzhf5nvp7w"))))
> +    (build-system meson-build-system)
> +    (inputs (list gtk qrencode))
> +    (native-inputs (list gettext-minimal pkg-config scdoc))
> +    (home-page "https://github.com/J-Lentz/iwgtk")
> +    (synopsis "Lightweight front-end for iwd")
> +    (description "Wireless networking GUI front-end for iwd, with supported
> +functionality similar to that of iwctl.  Features include viewing and connecting
> +to available networks, managing known networks, provisioning new networks via
> +WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status
> +and signal strength.")
> +    (license license:gpl3+)))
> +
>  (define-public libyang
>    (package
>      (name "libyang")
>
> base-commit: 91d9e145e15241c20729a4f1fa43f3d662f6b806

apply, see https://git.savannah.gnu.org/cgit/guix.git/commit/?id=33ddb5f312a1d0adf07b20f157d952f4c0276e8d
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9d657bc69d..dbc6280416 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -64,6 +64,7 @@ 
 ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2024 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -99,6 +100,7 @@  (define-module (gnu packages networking)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages adns)
+  #:use-module (gnu packages aidc)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autogen)
@@ -144,6 +146,7 @@  (define-module (gnu packages networking)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages mpi)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nettle)
@@ -4152,6 +4155,30 @@  (define-public iwd
 maximum extent possible.")
     (license license:lgpl2.1+)))
 
+(define-public iwgtk
+  (package
+    (name "iwgtk")
+    (version "0.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference (url "https://github.com/J-Lentz/iwgtk")
+                           (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fvxq4ydhzisfn93pcqbspqqi8fwj45v8q104bkm4qfzhf5nvp7w"))))
+    (build-system meson-build-system)
+    (inputs (list gtk qrencode))
+    (native-inputs (list gettext-minimal pkg-config scdoc))
+    (home-page "https://github.com/J-Lentz/iwgtk")
+    (synopsis "Lightweight front-end for iwd")
+    (description "Wireless networking GUI front-end for iwd, with supported
+functionality similar to that of iwctl.  Features include viewing and connecting
+to available networks, managing known networks, provisioning new networks via
+WPS or Wi-Fi Easy Connect, and an indicator icon displaying connection status
+and signal strength.")
+    (license license:gpl3+)))
+
 (define-public libyang
   (package
     (name "libyang")