diff mbox series

[bug#63213] gnu: lttng-tools: Fix build failure.

Message ID f86d122c9a81143dbb18e80099a7e76c68cde7a2.1682970338.git.olivier.dion@polymtl.ca
State New
Headers show
Series [bug#63213] gnu: lttng-tools: Fix build failure. | expand

Commit Message

Olivier Dion May 1, 2023, 7:46 p.m. UTC
* gnu/packages/instrumentation.scm (lttng-tools)
[native-inputs]: Add autoconf, automake, libtool.
[arguments]: Add 'autoreconf build phase before 'configure.
---
 gnu/packages/instrumentation.scm | 42 ++++++++++++++++++++++----------
 1 file changed, 29 insertions(+), 13 deletions(-)


base-commit: f21007ce4aceeacf5bbfc7cd45d526073141f194

Comments

Ludovic Courtès May 5, 2023, 9:56 p.m. UTC | #1
Olivier Dion <olivier.dion@polymtl.ca> skribis:

> * gnu/packages/instrumentation.scm (lttng-tools)
> [native-inputs]: Add autoconf, automake, libtool.
> [arguments]: Add 'autoreconf build phase before 'configure.

Applied, thanks!

Ludo'.
diff mbox series

Patch

diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..cbfb49370e 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -17,6 +17,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages instrumentation)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
@@ -376,7 +377,10 @@  (define-public lttng-tools
          (add-after 'unpack 'patch-default-man-path
            (lambda _
              (substitute* "src/common/defaults.h"
-               (("/usr/bin/man") "man")))))))
+               (("/usr/bin/man") "man"))))
+         (add-before 'configure 'autoreconf
+           (lambda _
+             (invoke "autoreconf" "-vfi"))))))
     ;; NOTE - Users have to install python-3 in their profile to use the
     ;; bindings.  We don't put it in the inputs, because the rest of the tools
     ;; can work without it.
@@ -384,19 +388,31 @@  (define-public lttng-tools
      (list liburcu popt numactl))
     (propagated-inputs
      (list kmod module-init-tools))
+    ;; NOTE - LTTng 2.13.9 is distributed with a aclocal.m4 that does not
+    ;; support Python3.10.  We can either disable Python's bindings or we can
+    ;; reconfigure the project with our autoconf.  This is because the
+    ;; distribution tarballs are generated on Ubuntu LTS 18.04.
+    ;;
+    ;; `paredit-raise-sexp' on the first list of native inputs and remove the
+    ;; 'autoreconf build step whenever we bump to the next version that is
+    ;; goind to be generated on Ubuntu LTS 22.04.
     (native-inputs
-     (list pkg-config
-           perl
-           libpfm4
-           python-3
-           swig
-           procps
-           which
-           flex
-           bison
-           asciidoc
-           libxml2
-           lttng-ust))
+     (append
+      (list pkg-config
+            perl
+            libpfm4
+            python-3
+            swig
+            procps
+            which
+            flex
+            bison
+            asciidoc
+            libxml2
+            lttng-ust)
+      (list autoconf
+            automake
+            libtool)))
     (home-page "https://lttng.org/")
     (synopsis "LTTng userspace tracer libraries")
     (description "The lttng-tools project provides a session