diff mbox series

[bug#72835,qt-team,32/38] gnu: Add qtconnectivity.

Message ID f82a90585121e5c2d40c3dddd47de0cc169fb52a.1724775512.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt6 to 6.7.2 | expand

Commit Message

Z572 Aug. 27, 2024, 4:25 p.m. UTC
* gnu/packages/qt.scm (qtconnectivity): New variable.

Change-Id: Ia2c1d9d260b47cd3a18c9ab5ac7e8f5ea83b7e11
---
 gnu/packages/qt.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Maxim Cournoyer Sept. 13, 2024, 3:28 p.m. UTC | #1
Hi Zheng,

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/qt.scm (qtconnectivity): New variable.
>
> Change-Id: Ia2c1d9d260b47cd3a18c9ab5ac7e8f5ea83b7e11
> ---
>  gnu/packages/qt.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 1956fec57a..df8759b832 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -1688,6 +1688,29 @@ (define-public qtconnectivity-5
>      (description "The Qt Connectivity modules provides modules for interacting
>  with Bluetooth and NFC.")))
>  
> +(define-public qtconnectivity
> +  (package
> +    (inherit qtsvg)
> +    (name "qtconnectivity")
> +    (version "6.6.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (qt-url name version))
> +              (sha256
> +               (base32
> +                "066mf4d6a81ywviwr8bvm1mpm2ykjzysvcc0v2x82h5bl28vl6h9"))))
> +    (native-inputs
> +     (list perl pkg-config qtdeclarative))
> +    (inputs
> +     (list bluez qtbase))
> +    (arguments (substitute-keyword-arguments (package-arguments qtsvg)
> +                 ((#:phases phases)
> +                  #~(modify-phases #$phases
> +                      (delete 'delete-installed-tests)))))
> +    (synopsis "Qt Connectivity module")
> +    (description "The Qt Connectivity modules provides modules for interacting
> +with Bluetooth and NFC.")))

I'm not sure about using inheritance this way; the packages are
unrelated. You'd at least want to ensure propagated-inputs is forced to
'() in case qtsvg had some added in the future.

I think I had refrained from using this style for Qt 6 thus far, as I
found it obfuscated the package definitions for Qt 5.

Could you rewrite it to use the style as used for example by
qtshadertools?  Only the home page and license fields need to be
specified.  So it's one field difference, and better clarity.

Could you please send a v2?
Z572 Sept. 18, 2024, 2:10 a.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi Zheng,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> * gnu/packages/qt.scm (qtconnectivity): New variable.
>>
>> Change-Id: Ia2c1d9d260b47cd3a18c9ab5ac7e8f5ea83b7e11
>> ---
>>  gnu/packages/qt.scm | 23 +++++++++++++++++++++++
>>  1 file changed, 23 insertions(+)
>>
>> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> index 1956fec57a..df8759b832 100644
>> --- a/gnu/packages/qt.scm
>> +++ b/gnu/packages/qt.scm
>> @@ -1688,6 +1688,29 @@ (define-public qtconnectivity-5
>>      (description "The Qt Connectivity modules provides modules for interacting
>>  with Bluetooth and NFC.")))
>>  
>> +(define-public qtconnectivity
>> +  (package
>> +    (inherit qtsvg)
>> +    (name "qtconnectivity")
>> +    (version "6.6.3")
>> +    (source (origin
>> +              (method url-fetch)
>> +              (uri (qt-url name version))
>> +              (sha256
>> +               (base32
>> +                "066mf4d6a81ywviwr8bvm1mpm2ykjzysvcc0v2x82h5bl28vl6h9"))))
>> +    (native-inputs
>> +     (list perl pkg-config qtdeclarative))
>> +    (inputs
>> +     (list bluez qtbase))
>> +    (arguments (substitute-keyword-arguments (package-arguments qtsvg)
>> +                 ((#:phases phases)
>> +                  #~(modify-phases #$phases
>> +                      (delete 'delete-installed-tests)))))
>> +    (synopsis "Qt Connectivity module")
>> +    (description "The Qt Connectivity modules provides modules for interacting
>> +with Bluetooth and NFC.")))
>
> I'm not sure about using inheritance this way; the packages are
> unrelated. You'd at least want to ensure propagated-inputs is forced to
> '() in case qtsvg had some added in the future.
>
> I think I had refrained from using this style for Qt 6 thus far, as I
> found it obfuscated the package definitions for Qt 5.
>
> Could you rewrite it to use the style as used for example by
> qtshadertools?  Only the home page and license fields need to be
> specified.  So it's one field difference, and better clarity.
>
> Could you please send a v2?

done.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1956fec57a..df8759b832 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1688,6 +1688,29 @@  (define-public qtconnectivity-5
     (description "The Qt Connectivity modules provides modules for interacting
 with Bluetooth and NFC.")))
 
+(define-public qtconnectivity
+  (package
+    (inherit qtsvg)
+    (name "qtconnectivity")
+    (version "6.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "066mf4d6a81ywviwr8bvm1mpm2ykjzysvcc0v2x82h5bl28vl6h9"))))
+    (native-inputs
+     (list perl pkg-config qtdeclarative))
+    (inputs
+     (list bluez qtbase))
+    (arguments (substitute-keyword-arguments (package-arguments qtsvg)
+                 ((#:phases phases)
+                  #~(modify-phases #$phases
+                      (delete 'delete-installed-tests)))))
+    (synopsis "Qt Connectivity module")
+    (description "The Qt Connectivity modules provides modules for interacting
+with Bluetooth and NFC.")))
+
 (define-public qtwebsockets-5
   (package (inherit qtsvg-5)
     (name "qtwebsockets")