From c16724c279309fd6fa58a927bd59862386f8a432 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Tue, 14 Apr 2020 21:10:07 +0530
Subject: [PATCH] gnu: libxfce4ui: Add 4.15.2.
* gnu/packages/xfce.scm (libxfce4ui): New variable.
---
gnu/packages/xfce.scm | 24 +++++++++++++++++++-----
1 file changed, 19 insertions(+), 5 deletions(-)
@@ -163,7 +163,7 @@ Xfce Desktop Environment.")
storage system.")
(license lgpl2.0+)))
-(define-public libxfce4ui
+(define-public libxfce4ui-1
(package
(name "libxfce4ui")
(version "4.14.1")
@@ -201,6 +201,20 @@ storage system.")
to share commonly used Xfce widgets among the Xfce applications.")
(license lgpl2.0+)))
+(define-public libxfce4ui
+ (package
+ (inherit libxfce4ui-1)
+ (name "libxfce4ui")
+ (version "4.15.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/xfce/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0069da27chxrgylbzcm9vhzpfnvkii2n2dz8g6jlwfcr82arkayb"))))))
+
(define-public exo
(package
(name "exo")
@@ -1313,7 +1327,7 @@ watch your every step.")
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+-2" ,gtk+-2)
- ("libxfce4ui" ,libxfce4ui)
+ ("libxfce4ui" ,libxfce4ui-1)
("xfce4-panel" ,xfce4-panel)))
(home-page
"https://goodies.xfce.org/projects/panel-plugins/xfce4-equake-plugin")
@@ -1450,7 +1464,7 @@ performance (bytes transferred per second).")
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("libxfce4ui" ,libxfce4ui)
+ `(("libxfce4ui" ,libxfce4ui-1)
("xfce4-panel" ,xfce4-panel)
("gtk+-2" ,gtk+-2)))
(home-page
@@ -1547,7 +1561,7 @@ button and a personalized tooltip.")
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+-2" ,gtk+-2)
- ("libxfce4ui" ,libxfce4ui)
+ ("libxfce4ui" ,libxfce4ui-1)
("xfce4-panel" ,xfce4-panel)))
(home-page
"https://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin")
@@ -1575,7 +1589,7 @@ Caps, Scroll and Num Lock in Xfce panel.")
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+-2" ,gtk+-2)
- ("libxfce4ui" ,libxfce4ui)
+ ("libxfce4ui" ,libxfce4ui-1)
("exo" ,exo)
("xfce4-panel" ,xfce4-panel)))
(home-page
--
2.25.1