diff mbox series

[bug#63095,core-updates,v7] gnu: ffmpeg: add svt-av1 support

Message ID f7fc73236a5173bfd1c9a004eda7b8b7132741cf.1700468400.git.atai@atai.org
State New
Headers show
Series [bug#63095,core-updates,v7] gnu: ffmpeg: add svt-av1 support | expand

Commit Message

Andy Tai Nov. 20, 2023, 8:20 a.m. UTC
* gnu/packages/video.scm (ffmpeg): Add support for svt-av1
[inputs]: Add svt-av1
[arguments] (configure-flags): Add "--enable-libsvtav1"
---
 gnu/packages/video.scm | 2 ++
 1 file changed, 2 insertions(+)


base-commit: 71b92466430acb8c91841522dc0eb7d766af4388

Comments

Andy Tai Jan. 15, 2024, 6:19 p.m. UTC | #1
Maxim, you updated ffmpeg in the core-updates branch of Guix.  Can the
patch in issue 63095

https://issues.guix.gnu.org/63095#14

be also pushed into the core-updates branch if it looks good to you?
else ffmpeg updates will cause rebuild of more than 1000 packages and
this just cnnnot be passed on Guix QA as Guix Qa cannot rebuild that
many packages now for building check of packages. Nor it makes sense
to have a feature branch just for this change. Thanks

On Mon, Nov 20, 2023 at 12:20 AM Andy Tai <atai@atai.org> wrote:
>
> * gnu/packages/video.scm (ffmpeg): Add support for svt-av1
> [inputs]: Add svt-av1
> [arguments] (configure-flags): Add "--enable-libsvtav1"
> ---
>  gnu/packages/video.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 561268aabd..ac47a33633 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -1625,6 +1625,7 @@ (define-public ffmpeg
>              soxr
>              speex
>              srt
> +            svt-av1
>              twolame
>              vidstab
>              x265
> @@ -1713,6 +1714,7 @@ (define-public ffmpeg
>           "--enable-libsoxr"
>           "--enable-libspeex"
>           "--enable-libsrt"
> +         "--enable-libsvtav1"
>           "--enable-libtheora"
>           "--enable-libtwolame"
>           "--enable-libvidstab"
>
> base-commit: 71b92466430acb8c91841522dc0eb7d766af4388
> --
> 2.41.0
>
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 561268aabd..ac47a33633 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1625,6 +1625,7 @@  (define-public ffmpeg
             soxr
             speex
             srt
+            svt-av1
             twolame
             vidstab
             x265
@@ -1713,6 +1714,7 @@  (define-public ffmpeg
          "--enable-libsoxr"
          "--enable-libspeex"
          "--enable-libsrt"
+         "--enable-libsvtav1"
          "--enable-libtheora"
          "--enable-libtwolame"
          "--enable-libvidstab"