diff mbox series

[bug#74223,04/11] gnu: Add hyprland-protocols.

Message ID f7d75c407e28175a9d28cb2c37f501bcda254291.1730877074.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add hyprland. | expand

Commit Message

Hilton Chain Nov. 6, 2024, 7:36 a.m. UTC
* gnu/packages/wm.scm (hyprland-protocols): New variable.

Change-Id: If986f2b5f8c0070807484e60431bb4c47f901edc
---
 gnu/packages/freedesktop.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 57d3322139..7969603613 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1340,6 +1340,26 @@  (define-public python-pyxdg
 Python.")
     (license license:lgpl2.0)))
 
+(define-public hyprland-protocols
+  (package
+    (name "hyprland-protocols")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hyprwm/hyprland-protocols")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0x86w7z3415qvixfhk9a8v5fnbnxdydzx366qz0mpmfg5h86qyha"))))
+    (build-system meson-build-system)
+    (home-page "https://github.com/hyprwm/hyprland-protocols")
+    (synopsis "Wayland protocol extensions for Hyprland")
+    (description
+     "This package provides Wayland protocol extensions for Hyprland.")
+    (license license:bsd-3)))
+
 (define-public hyprwayland-scanner
   (package
     (name "hyprwayland-scanner")