diff mbox series

[bug#67450] gnu: grep: Fix pcre matching in grep.

Message ID f7a9ab63-9e03-3793-f301-7f45a78d7186@purge.sh
State New
Headers show
Series [bug#67450] gnu: grep: Fix pcre matching in grep. | expand

Commit Message

spacecadet Nov. 26, 2023, 3:12 a.m. UTC
Fix grep not building with -P (perl regexp) support.

* gnu/packages/base.scm: Replace grep's pcre input with pcre2.
* gnu/packages/base.scm: Add "--enable-perl-regexp" configure flag to grep.
---
  gnu/packages/base.scm | 6 ++++--
  1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: 13bc0633e77c73389e530a4c45e2de5a823f106b

Comments

Tobias Geerinckx-Rice Nov. 26, 2023, 1:59 p.m. UTC | #1
Hi!

(Please don't hesitate to submit bug fixes upstream, especially 
when the breakage is so clearly unintentional :-)

I changed the changelog to better follow our standards

    gnu: grep: Fix PCRE matches (grep -P).

    {{{No blurb here if it only rephrases the title.}}}

    * gnu/packages/base.scm (grep)[inputs]: Replace pcre with 
    pcre2.
    [arguments]: Add "--enable-perl-regexp" to #:configure-flags 
    to
    detect broken PCRE in future.

and pushed this to core-updates as 
5b0cea02358044f0cc695bacc3f44db1e220239b.

Thanks,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 41aff0ca97..feb5ca5746 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -120,9 +120,11 @@  (define-public grep
              (patches (search-patches "grep-timing-sensitive-test.patch"))))
     (build-system gnu-build-system)
     (native-inputs (list perl))                   ;some of the tests require it
-   (inputs (list pcre))
+   (inputs (list pcre2))
     (arguments
-    `(#:phases
+    `(#:configure-flags
+      (list "--enable-perl-regexp")
+      #:phases
        (modify-phases %standard-phases
          (add-after 'install 'fix-egrep-and-fgrep
            ;; Patch 'egrep' and 'fgrep' to execute 'grep' via its