diff mbox series

[bug#74353] gnu: hdf5: Remove machine info from libraries.

Message ID f785ad2cb0da0bccac1dac71b591f0554b3e926a.1731595771.git.lars.bilke@ufz.de
State New
Headers show
Series [bug#74353] gnu: hdf5: Remove machine info from libraries. | expand

Commit Message

Lars Bilke Nov. 14, 2024, 2:49 p.m. UTC
Change-Id: I1435b866babeb95af48e0fd970d931f022c8bc67
---
 gnu/packages/maths.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)


base-commit: b10ce47d8be5b6c15987f4e1d93b3bd71b1eb220
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bb6c1648b5..89fb9291b8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1726,7 +1726,14 @@  (define-public hdf5-1.14
                 ;; modifies the test reference.
                 (substitute* "test/test_check_version.sh.in"
                   (("TESTING\\(\\).*" all)
-                   (string-append all "\nSKIP; exit 0\n")))))))))))
+                   (string-append all "\nSKIP; exit 0\n")))))
+            (add-after 'patch-configure 'patch-configure-build-settings
+              (lambda _
+                (substitute* "src/H5build_settings.autotools.c.in"
+                  ;; Don't record the build-time kernel version to make the
+                  ;; library file reproducible.
+                  (("@UNAME_INFO@")
+                   "Linux"))))))))))
 
 (define-public hdf5
   ;; Default version of HDF5.