diff mbox series

[bug#57625,2/3] gnu: Add treecc.

Message ID f714b160-5ea4-9bdd-d4f0-46434f68e1fb@disroot.org
State New
Headers show
Series WIP: Add pnet. | expand

Commit Message

Adam Faiz Sept. 6, 2022, 3:39 p.m. UTC
From 72b17b99a7318626dd41db831201c9df64e4defd Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 6 Sep 2022 15:51:16 +0800
Subject: [PATCH 2/3] gnu: Add treecc.

* gnu/packages/dotgnu.scm: New file.
---
  gnu/packages/dotgnu.scm | 52 +++++++++++++++++++++++++++++++++++++++++
  1 file changed, 52 insertions(+)
  create mode 100644 gnu/packages/dotgnu.scm

handle
+abstract syntax trees and operations upon the trees.")
+    (license license:gpl2+)))

Comments

M Sept. 6, 2022, 6:07 p.m. UTC | #1
On 06-09-2022 17:39, Adam Faiz via Guix-patches via wrote:
>
> +  (package
> +    (name "treecc")
> +    (version "0.3.10")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> + "https://download.savannah.gnu.org/releases/dotgnu-pnet/treecc-"
> +                    version ".tar.gz"))
> +              (sha256
> +               (base32
> + "1rzgnspg2xccdq3qsx0vi3j28h4qkrzbrjnhzvnny34fjfk217ay")))) 

Similarly to pnet, configure, Makefile.in, ..., config.sub and 
config.guess need to be regenerated too.

config.sub and config.guess are particularly important, old versions 
don't support new architectures. E.g., the bundled config.sub does not 
support aarch64.

Greetings,
Maxime
diff mbox series

Patch

diff --git a/gnu/packages/dotgnu.scm b/gnu/packages/dotgnu.scm
new file mode 100644
index 0000000000..14e11b3653
--- /dev/null
+++ b/gnu/packages/dotgnu.scm
@@ -0,0 +1,52 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dotgnu)
+  #:use-module ((guix licenses)
+                #:prefix license:)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bdw-gc)
+  #:use-module (gnu packages libffi)
+  #:use-module (gnu packages)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu))
+
+(define-public treecc
+  (package
+    (name "treecc")
+    (version "0.3.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+ 
"https://download.savannah.gnu.org/releases/dotgnu-pnet/treecc-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1rzgnspg2xccdq3qsx0vi3j28h4qkrzbrjnhzvnny34fjfk217ay"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/dotgnu/")
+    (synopsis "Abstract syntax tree compiler compiler")
+    (description
+     "The treecc program is designed to assist in the development of 
compilers
+and other language-based tools.  It manages the generation of code to