diff mbox series

[bug#39514] update radare2 and cutter versions

Message ID f70aaac9daabf248f299992ac10ee55d@airmail.cc
State Accepted
Headers show
Series [bug#39514] update radare2 and cutter versions | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe Feb. 8, 2020, 3:53 p.m. UTC
update radare2 and cutter, they need to be updated at the same time 
since old cutter doesn't build with new radare2 and new cutter doesn't 
build with old radare2
---
  gnu/packages/engineering.scm | 20 +++++++++++---------
  1 file changed, 11 insertions(+), 9 deletions(-)

                (modules '((guix build utils)))
                (snippet
                 '(begin
@@ -1290,7 +1292,7 @@ bindings for Python, Java, OCaml and more.")
                    #t))))
      (build-system gnu-build-system)
      (arguments
-     '(#:tests? #f                      ; tests require git and network 
access
+     '(#:tests? #f              ; tests require git and network access
         #:phases
         (modify-phases %standard-phases
           (add-before 'configure 'mklibdir
@@ -1312,7 +1314,7 @@ bindings for Python, Java, OCaml and more.")
      (home-page "https://radare.org/")
      (synopsis "Portable reversing framework")
      (description
-      "Radare project started as a forensics tool, a scriptable 
commandline
+     "Radare project started as a forensics tool, a scriptable 
commandline
  hexadecimal editor able to open disk files, but later support for 
analyzing
  binaries, disassembling code, debugging programs, attaching to remote 
gdb
  servers, ...")
@@ -2089,7 +2091,7 @@ simulation.")
  (define-public cutter
    (package
      (name "cutter")
-    (version "1.8.3")
+    (version "1.10.1")
      (source
       (origin
         (method git-fetch)
@@ -2099,7 +2101,7 @@ simulation.")
         (file-name (git-file-name name version))
         (sha256
          (base32
-         "03f3cdckh51anx9gd1b0ndb2fg7061hqngvygf32ky29mm2m2lyv"))))
+         "1gvsrcskcdd1hxrjpkpc657anmfs25f174vxk4wzvn385rnmrxd3"))))
      (build-system gnu-build-system)
      (arguments
       `(#:phases

Comments

kiasoc5--- via Guix-patches via Feb. 15, 2020, 12:38 p.m. UTC | #1
Pinoaffe,

pinoaffe@airmail.cc 写道:
> update radare2 and cutter, they need to be updated at the same 
> time
> since old cutter doesn't build with new radare2 and new cutter 
> doesn't
> build with old radare2

This is a good reason not to separate the two, although I'm unsure 
what the commit message would look like.

> -    (version "3.5.1")
> +    (version "4.2.1")

Confusingly, their ‘releases’ page[0] lists 4.2.0 as ‘Latest 
release’.  As GitHub actively encourages poor release management 
this might just be an oversight, but it would be nice if this were 
clarified.  Is 4.2.1 generally accepted as the current stable 
release?

> +              (file-name (string-append name "-" version 
> "-checkout"))

There's a (git-file-name name version) helper that will do the 
same thing, prettier.

>      (description
> -      "Radare project started as a forensics tool, a scriptable
> commandline
> +     "Radare project started as a forensics tool, a scriptable

I'm going to improve the radare2 description on master so this 
hunk can be dropped.

Would you be willing to send a V2 patch to this bug number (and 
think of a good commit message following our standards[1])?  

Kind regards,

T G-R

[0]: https://github.com/radareorg/radare2/releasesu
[1]: https://guix.gnu.org/manual/en/guix.html#Submitting-Patches
Maja Kądziołka March 28, 2020, 11:14 p.m. UTC | #2
These got pushed as two commits about a week ago by Ludovic, but it
seems he forgot to close the bug.

For reference:

commit 6f3475655a60e25328d6fc8a1ce4af19620f0a02
Author: pinoaffe@airmail.cc <pinoaffe@airmail.cc>
Date:   Sat Mar 21 08:58:35 2020 +0000

    gnu: cutter: Update to 1.10.1.

    * gnu/packages/engineering.scm (cutter): Update to 1.10.1.

    Signed-off-by: Ludovic Courtès <ludo@gnu.org>

commit fcc10cb2cbde9c104d394167ba354b0c9f2cd752
Author: pinoaffe@airmail.cc <pinoaffe@airmail.cc>
Date:   Sat Mar 21 08:57:21 2020 +0000

    gnu: radare2: Update to 4.2.1.

    * gnu/packages/engineering.scm (radare2): Update to 4.2.1.

    Signed-off-by: Ludovic Courtès <ludo@gnu.org>
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4db8109249..f76c2800e4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1270,14 +1270,16 @@  bindings for Python, Java, OCaml and more.")
  (define-public radare2
    (package
      (name "radare2")
-    (version "3.5.1")
+    (version "4.2.1")
      (source (origin
-              (method url-fetch)
-              (uri (string-append "https://radare.mikelloc.com/get/" 
version "/"
-                                  "radare2-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/radareorg/radare2")
+                    (commit version)))
                (sha256
                 (base32
-                
"174x5545fw2nyf000gd46hi7rx2bn3bw5bsnvizn9yi99pn7m4mw"))
+                
"14b9433cgc2nabhz836zfgvgh2dwailcmvy05krsa0inmzbvx9fg"))
+              (file-name (string-append name "-" version "-checkout"))