[bug#75554] gnu: Add cl-trivial-battery

Message ID f6c02d69610aefdd37350f19dddeb12171b51fc8.1736796132.git.dk@junkeria.club
State New
Headers
Series [bug#75554] gnu: Add cl-trivial-battery |

Commit Message

Junker Jan. 14, 2025, 8:16 a.m. UTC
  Change-Id: Icdcf77738ba71e4705410aadedd6fe6f7babf1e1
---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 9edb4fe373893becde2ce3e6703b33093fd0b04a
  

Comments

Junker Jan. 18, 2025, 11:24 a.m. UTC | #1
This is my first patch with a new package, and I would appreciate any feedback you might have.
  
Guillaume Le Vaillant Jan. 22, 2025, 1:34 p.m. UTC | #2
Patch applied as 98a494f0000c334069bae692d92ca0b8a4372e28 with some
minor modifications:

 - Used the "cl-trivial-battery" name explicitly in 'git-file-name' (we
   usually do that for Common Lisp packages, otherwise the sources would
   be named "sbcl-trivial-battery" although they are not specific to
   sbcl, as they are also used for the cl-trivial-battery and
   ecl-trivial-battery packages).

 - Simplified the synopsis so that it is not a full sentence.

 - Kept the line length of the description field below 80 characters.

 - Added the missing line in the commit message.

Thanks.
  

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e799e1a8e..61204ca4e2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -29978,6 +29978,35 @@  (define-public cl-trivial-backtrace
 (define-public ecl-trivial-backtrace
   (sbcl-package->ecl-package sbcl-trivial-backtrace))
 
+(define-public sbcl-trivial-battery
+  (let ((commit "318c9da88b4d11d3f33062e0fd09be660a383404")
+        (revision "1"))
+    (package
+      (name "sbcl-trivial-battery")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pokepay/trivial-battery")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "12ni2502v9gjszhjsh0aai08cm64gl8g815xghdjhcf7y34ffl2b"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs (list sbcl-split-sequence))
+      (home-page "https://github.com/pokepay/trivial-battery")
+      (synopsis "A trivial library for getting the battery information.")
+      (description
+       "This package provides a Common Lisp library for getting the battery information.")
+      (license license:bsd-2))))
+
+(define-public cl-trivial-battery
+  (sbcl-package->cl-source-package sbcl-trivial-battery))
+
+(define-public ecl-trivial-battery
+  (sbcl-package->ecl-package sbcl-trivial-battery))
+
 (define-public sbcl-trivial-benchmark
   (let ((commit "1fbc8d15f09ed8aa426bc73956b8b7c9b2668802")
         (revision "2"))