[bug#76746,v2,03/13] gnu: python-rich: Update to 13.9.4.
Commit Message
* gnu/packages/python-xyz.scm (python-rich): Update to 13.9.4.
[source]{url}: Use new GitHub repository.
[arguments]{test-flags}: Skip another failing test.
[native-inputs]: Add which.
Change-Id: Iea6416016e24e0e2684bbf6a767401834fbb581b
---
gnu/packages/python-xyz.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
@@ -21824,23 +21824,24 @@ (define-public python-slugid
(define-public python-rich
(package
(name "python-rich")
- (version "13.7.1")
+ (version "13.9.4")
(source
(origin
;; There are no tests in the PyPI tarball.
(method git-fetch)
(uri (git-reference
- (url "https://github.com/willmcgugan/rich")
+ (url "https://github.com/Textualize/rich")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0jvkcp473c0icbb8md3grc3285j2cy0z0swxgk2g67d9n0zfdfzc"))))
+ "03qqipjjxpp4c984nzr667k9sa15bmbkzl0865jkyjvy6kvjkak5"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- ;; These fail for unknown reasons, but the results look identical.
+ ;; These fail for unknown reasons. The results look nearly identical
+ ;; except for some minor differences in the colors.
;; Perhaps only the terminal escape sequences are superficially
;; different?
'(list "-k" (string-append "not test_card_render"
@@ -21849,12 +21850,14 @@ (define-public python-rich
" and not test_python_render_simple"
" and not test_python_render_simple_passing_lexer_instance"
" and not test_python_render_indent_guides"
+ " and not test_background_color_override_includes_padding"
" and not test_option_no_wrap"
" and not test_syntax_highlight_ranges"))))
(propagated-inputs
(list python-markdown-it-py python-pygments))
(native-inputs
- (list python-poetry-core python-pytest))
+ (list which ;needed by test_brokenpipeerror
+ python-poetry-core python-pytest))
(home-page "https://github.com/willmcgugan/rich")
(synopsis "Render rich text and more to the terminal")
(description