diff mbox series

[bug#45889] Nextcloud Client (v14)

Message ID f6b95086-a9db-4bea-7b4d-9bb418b717e2@raghavgururajan.name
State Accepted
Headers show
Series [bug#45889] Nextcloud Client (v14) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 23, 2021, 2:27 p.m. UTC

Comments

Leo Prikler Feb. 23, 2021, 5:58 p.m. UTC | #1
Hi Raghav,

Am Dienstag, den 23.02.2021, 09:27 -0500 schrieb Raghav Gururajan:
> +             (let* ((qtsolutions (assoc-ref inputs "qtsolutions")))
> +               (for-each
> +                (lambda (dir)
> +                  (copy-recursively
> +                   (string-append qtsolutions "/" dir "/src")
> +                   (string-append "src/3rdparty/" dir)))
> +                '("qtlockedfile" "qtsingleapplication")))
> +             (with-directory-excursion "src/gui"
> +               (substitute* `("application.h" "application.cpp")
> +                 (("SharedTools::QtSingleApplication")
> "QtSingleApplication")
> +                 (("slotParseMessage\\(const QString &(msg)?.*\\)")
> +                  "slotParseMessage(const QString &msg)")))
Being the one who helped review this, I of course know, what it does,
but others might not, so this probably deserves a (short) comment.

> +       ("qtsolutions"
> +        ,(origin
> +           (method git-fetch)
> +           (uri
> +            (git-reference
> +             (url "https://github.com/qtproject/qt-solutions")
> +             (commit "9568abd142d581b67b86a5f63d823a34b0612702")))
> +           (file-name
> +            (git-file-name "qtsolutions" "9568abd"))
> +           (sha256
> +            (base32
> "17fnmassflm3vxi0krpr6fff368jy38cby31a48rban4nqqmgx7n"))))
I'm still not convinced, that this can't be made a package or perhaps
multiple packages, one per "solution".  Each of the folder seems to
contain a project file, which to be fair do have some non-Unix-related
install declarations, but it should at least install a statically
linked package *somewhere*.  We can go from there.

Alternatively, as I see this as a source, that will get copied around
in the same way I copied libgd from gedit, you can at least extract the
origin into a function in qt.scm, potentially named qt-solutions.

Regards,
Leo
diff mbox series

Patch

From b3df8c3b3f5d3e3cc286b95df1928c81edba3556 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Tue, 23 Feb 2021 08:24:47 -0500
Subject: [PATCH 2/2] gnu: Add nextcloud-client.

* gnu/packages/sync.scm (nextcloud-client): New variable.
---
 gnu/packages/sync.scm | 148 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 148 insertions(+)

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index f3d6e9013c..a3a1dda240 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -28,6 +28,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
+  #:use-module (guix build-system qt)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
@@ -40,8 +41,11 @@ 
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages linux)
@@ -49,14 +53,158 @@ 
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rsync)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages selinux)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls))
 
+(define-public nextcloud-client
+  (package
+    (name "nextcloud-client")
+    (version "3.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/nextcloud/desktop")
+         (commit
+          (string-append "v" version))))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "15ymk3gvfmgwzmqbhlw7jjy9y65ib3391h1dlmpll65iaj2miajk"))
+       (modules '((guix build utils)
+                  (ice-9 ftw)
+                  (srfi srfi-1)))
+       (snippet
+        `(begin
+           (let ((keep '( ;; Not available in Guix.
+                         "QProgressIndicator"
+                         "kmessagewidget" "qtokenizer")))
+             (with-directory-excursion "src/3rdparty"
+               (for-each delete-file-recursively
+                         (lset-difference string=?
+                                          (scandir ".")
+                                          (cons* "." ".." keep))))
+             #t)))))
+    (build-system qt-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "-DUNIT_TESTING=ON"
+        ;; Upstream Bug: https://github.com/nextcloud/desktop/issues/2885
+        "-DNO_SHIBBOLETH=ON")
+       #:imported-modules
+       ((guix build glib-or-gtk-build-system)
+        ,@%qt-build-system-modules)
+       #:modules
+       (((guix build glib-or-gtk-build-system)
+         #:prefix glib-or-gtk:)
+        (guix build qt-build-system)
+        (guix build utils))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((qtsolutions (assoc-ref inputs "qtsolutions")))
+               (for-each
+                (lambda (dir)
+                  (copy-recursively
+                   (string-append qtsolutions "/" dir "/src")
+                   (string-append "src/3rdparty/" dir)))
+                '("qtlockedfile" "qtsingleapplication")))
+             (with-directory-excursion "src/gui"
+               (substitute* `("application.h" "application.cpp")
+                 (("SharedTools::QtSingleApplication") "QtSingleApplication")
+                 (("slotParseMessage\\(const QString &(msg)?.*\\)")
+                  "slotParseMessage(const QString &msg)")))
+             #t))
+         (add-after 'patch-source 'patch-cmake
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Patch install directory for dbus service files.
+             (substitute* "shell_integration/libcloudproviders/CMakeLists.txt"
+               (("PKGCONFIG_GETVAR\\(.+ _install_dir\\)")
+                "set(_install_dir \"${CMAKE_INSTALL_PREFIX}/share/dbus-1/services\")"))
+             ;; Make sure, that Qt modules are installed under $prefix.
+             (substitute* "shell_integration/dolphin/CMakeLists.txt"
+               (("ON CACHE")
+                "OFF CACHE"))
+             #t))
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests write to $HOME.
+             (setenv "HOME" (getcwd))
+             #t))
+         (add-after 'install 'glib-or-gtk-compile-schemas
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+         (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+    (native-inputs
+     `(("cmocka" ,cmocka)
+       ("dot" ,graphviz)
+       ("doxygen" ,doxygen)
+       ("extra-cmake-modules" ,extra-cmake-modules)
+       ("glib:bin" ,glib "bin")
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)
+       ("qtsolutions"
+        ,(origin
+           (method git-fetch)
+           (uri
+            (git-reference
+             (url "https://github.com/qtproject/qt-solutions")
+             (commit "9568abd142d581b67b86a5f63d823a34b0612702")))
+           (file-name
+            (git-file-name "qtsolutions" "9568abd"))
+           (sha256
+            (base32 "17fnmassflm3vxi0krpr6fff368jy38cby31a48rban4nqqmgx7n"))))
+       ("qttools" ,qttools)
+       ("ruby" ,ruby)))
+    (inputs
+     `(("appstream" ,appstream)
+       ("glib" ,glib)
+       ("kconfig" ,kconfig)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kio" ,kio)
+       ("kjs" ,kjs)
+       ("libcloudproviders" ,libcloudproviders)
+       ("libzip" ,libzip)
+       ("openssl" ,openssl)
+       ("python-nautilus" ,python-nautilus)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtkeychain" ,qtkeychain)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("qtsvg" ,qtsvg)
+       ("qtwebchannel" ,qtwebchannel)
+       ("qtwebsockets" ,qtwebsockets)
+       ("qtwebkit" ,qtwebkit)
+       ("sqlite" ,sqlite)
+       ("zlib" ,zlib)))
+    (propagated-inputs
+     `(("qtwebengine" ,qtwebengine)))
+    (synopsis "Desktop sync client for Nextcloud")
+    (description "Nextcloud-Desktop is a tool to synchronize files from
+Nextcloud Server with your computer.")
+    (home-page "https://nextcloud.com/install/#install-clients")
+    (license
+     (list
+      ;; QtProgressIndicator
+      license:expat
+      ;; All ThirdParty (except QtProgressIndicator)
+      license:lgpl2.1+
+      ;; Others
+      license:gpl2+))))
+
 (define-public megacmd
   (package
     (name "megacmd")
-- 
2.30.1