diff mbox series

[bug#45889] Nextcloud Client (v16)

Message ID f6b923c8-1f26-3d57-602e-83d9488a85e8@raghavgururajan.name
State Accepted
Headers show
Series [bug#45889] Nextcloud Client (v16) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 9, 2021, 10:50 a.m. UTC
Hi Leo!

> Try not to arbitrarily use too many new lines.  If you break Scheme
> code in such a manner for no good reason, it will look odd.

Done.

> Why not to UTF-8?

Done.

> You should install the shared libraries in the install phase.

Done.

> Use '(...) for fixed input.

Done.

> I'm starting to grow a little suspicious about matching the leading
> spaces.  You probably want to lead this (and similar stuff in 0001)
> with [ \t]*.

Done.

> LGTM, but probably deserves a comment.

Done.

> Definitely deserves a comment and perhaps a less broad match?

Done the comment.

I think this is perfect match. The mentioned libraries will get linked 
wherever synclib gets linked. Also, this patch is compatible with 
current master, which is different from this version.

> Also deserves a comment about QtSingleApplication differences.

Done.

> Would the raw string here exceed a line?

Yep!

> This is now just qtokenizer, right?

Changed.

Please find the attached v16.

Regards,
RG.

Comments

Leo Prikler March 9, 2021, 11:39 a.m. UTC | #1
Hi Raghav,

Mostly LGTM.

Am Dienstag, den 09.03.2021, 05:50 -0500 schrieb Raghav Gururajan:
> > Definitely deserves a comment and perhaps a less broad match?
> 
> Done the comment.
> 
> I think this is perfect match. The mentioned libraries will get
> linked 
> wherever synclib gets linked. Also, this patch is compatible with 
> current master, which is different from this version.
Perhaps the comment should reflect that a little better.  You might
also want to expand that during the unvendoring in the snippet, so that
it's less confusing.

> +                                    `(("src" ,(string-append
> "include/" solution)
> +                                       #:include-regexp ("\\.h$"))
I think you should unvendor dependencies between the solutions, so that
you can put them in "include/" directly (like putting the solutions in
"/lib").

Regards,
Leo
diff mbox series

Patch

From e52d1d8e4a602254c68be6739a18dedaf02d9ff2 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Tue, 9 Mar 2021 02:19:00 -0500
Subject: [PATCH 3/3] gnu: Add nextcloud-client.

* gnu/packages/messaging.scm (nextcloud-client): New variable.
---
 gnu/packages/sync.scm | 160 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 160 insertions(+)

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d7c9009f3b..9aa7e9f866 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -30,6 +30,7 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system meson)
+  #:use-module (guix build-system qt)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
@@ -42,8 +43,11 @@ 
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages linux)
@@ -52,15 +56,171 @@ 
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rsync)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages selinux)
   #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls))
 
+(define-public nextcloud-client
+  (package
+    (name "nextcloud-client")
+    (version "3.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/nextcloud/desktop")
+         (commit
+          (string-append "v" version))))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "15ymk3gvfmgwzmqbhlw7jjy9y65ib3391h1dlmpll65iaj2miajk"))
+       (modules '((guix build utils)
+                  (ice-9 ftw)
+                  (srfi srfi-1)))
+       (snippet
+        `(begin
+           ;; Not available in Guix.
+           (let* ((keep '("QProgressIndicator" "qtokenizer")))
+             (with-directory-excursion "src/3rdparty"
+               (for-each delete-file-recursively
+                         (lset-difference string=?
+                                          (scandir ".")
+                                          (cons* "." ".." keep))))
+             #t)))))
+    (build-system qt-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "-DUNIT_TESTING=ON"
+        ;; Upstream Bug: https://github.com/nextcloud/desktop/issues/2885
+        "-DNO_SHIBBOLETH=ON")
+       #:imported-modules
+       ((guix build glib-or-gtk-build-system)
+        ,@%qt-build-system-modules)
+       #:modules
+       (((guix build glib-or-gtk-build-system)
+         #:prefix glib-or-gtk:)
+        (guix build qt-build-system)
+        (guix build utils))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (with-directory-excursion "src/gui"
+               (substitute* "CMakeLists.txt"
+                 ;; Remove source references of deleted 3rdparties.
+                 (("[ \t]*\\.\\./3rdparty/qtlockedfile/?.*\\.cpp")
+                  "")
+                 (("[ \t]*\\.\\./3rdparty/qtsingleapplication/?.*\\.cpp")
+                  "")
+                 (("[ \t]*\\.\\./3rdparty/kmessagewidget/?.*\\.cpp")
+                  "")
+                 (("[ \t]*list\\(APPEND 3rdparty_SRC \\.\\./3rdparty/?.*\\)")
+                  "")
+                 ;; Patch include references of deleted 3rdparties to inputs.
+                 (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/qtlockedfile")
+                  (string-append (assoc-ref inputs "qtsolutions")
+                                 "/include/qtlockedfile/"))
+                 (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/qtsingleapplication")
+                  (string-append (assoc-ref inputs "qtsolutions")
+                                 "/include/qtsingleapplication/"))
+                 (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/kmessagewidget")
+                  (string-append (assoc-ref inputs "kwidgetsaddons")
+                                 "/include/KF5/KWidgetsAddons/"))
+                 ;; Link libraries from inputs that were deleted in 3rdparty.
+                 (("\\$\\{synclib_NAME\\}")
+                  (string-append "${synclib_NAME} "
+                                 "QtSolutions_LockedFile "
+                                 "QtSolutions_SingleApplication "
+                                 "KF5WidgetsAddons")))
+               ;; Fix compatibility with QtSingleApplication from QtSolutions.
+               (substitute* '("application.h" "application.cpp")
+                 (("SharedTools::QtSingleApplication")
+                  "QtSingleApplication")
+                 (("slotParseMessage\\(const QString &(msg)?.*\\)")
+                  "slotParseMessage(const QString &msg)")))
+             #t))
+         (add-after 'patch-source 'patch-cmake
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Patch install directory for dbus service files.
+             (substitute* "shell_integration/libcloudproviders/CMakeLists.txt"
+               (("PKGCONFIG_GETVAR\\(.+ _install_dir\\)")
+                (string-append "set(_install_dir \"${CMAKE_INSTALL_PREFIX}"
+                               "/share/dbus-1/services\")")))
+             ;; Make sure, that Qt modules are installed under $prefix.
+             (substitute* "shell_integration/dolphin/CMakeLists.txt"
+               (("ON CACHE")
+                "OFF CACHE"))
+             #t))
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests write to $HOME.
+             (setenv "HOME" (getcwd))
+             #t))
+         (add-after 'install 'glib-or-gtk-compile-schemas
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+         (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+    (native-inputs
+     `(("cmocka" ,cmocka)
+       ("dot" ,graphviz)
+       ("doxygen" ,doxygen)
+       ("extra-cmake-modules" ,extra-cmake-modules)
+       ("glib:bin" ,glib "bin")
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)
+       ("qttools" ,qttools)
+       ("ruby" ,ruby)))
+    (inputs
+     `(("appstream" ,appstream)
+       ("glib" ,glib)
+       ("kconfig" ,kconfig)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kio" ,kio)
+       ("kjs" ,kjs)
+       ("kwidgetsaddons" ,kwidgetsaddons)
+       ("libcloudproviders" ,libcloudproviders)
+       ("libzip" ,libzip)
+       ("openssl" ,openssl)
+       ("python-nautilus" ,python-nautilus)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtkeychain" ,qtkeychain)
+       ("qtquickcontrols2" ,qtquickcontrols2)
+       ("qtsolutions" ,qtsolutions)
+       ("qtsvg" ,qtsvg)
+       ("qtwebchannel" ,qtwebchannel)
+       ("qtwebsockets" ,qtwebsockets)
+       ("qtwebkit" ,qtwebkit)
+       ("sqlite" ,sqlite)
+       ("zlib" ,zlib)))
+    (propagated-inputs
+     `(("qtwebengine" ,qtwebengine)))
+    (synopsis "Desktop sync client for Nextcloud")
+    (description "Nextcloud-Desktop is a tool to synchronize files from
+Nextcloud Server with your computer.")
+    (home-page "https://nextcloud.com/install/#install-clients")
+    (license
+     (list
+      ;; QtProgressIndicator
+      license:expat
+      ;; Qtokenizer
+      license:lgpl2.1+
+      ;; Others
+      license:gpl2+))))
+
 (define-public megacmd
   (package
     (name "megacmd")
-- 
2.30.1