diff mbox series

[bug#50405] python-packaging: upgrade to 20.9

Message ID f6a3fb84-67df-a21c-95e8-c1bd5b0bba98@arctype.co
State New
Headers show
Series [bug#50405] python-packaging: upgrade to 20.9 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Sundberg Sept. 5, 2021, 4:33 p.m. UTC
Upgrade python-packaging from 20.0 to 20.9. Also conveniently removes a
patch file that is now upstream.


--
Sincerely,
Ryan Sundberg

Comments

Vagrant Cascadian Sept. 1, 2023, 8:29 p.m. UTC | #1
On 2021-09-05, Ryan Sundberg wrote:
> Upgrade python-packaging from 20.0 to 20.9. Also conveniently removes a
> patch file that is now upstream.

python-packaging has since been upgraded to an even newer version,
currently 21.3.

live well,
  vagrant
diff mbox series

Patch

From 485b5c2f0717f4d79ae0376b2a06a4383141a650 Mon Sep 17 00:00:00 2001
From: Ryan Sundberg <ryan@arctype.co>
Date: Mon, 3 May 2021 00:42:08 -0700
Subject: [PATCH] python-packaging: upgrade to 20.9

* gnu/local.mk: Remove patch file gnu/packages/patches/python-packaging-test-arch.patch
* gnu/packages/patches/python-packaging-test-arch.patch: Deleted
* gnu/packages/python-xyz.scm (python-packaging): Upgrade to 20.9. Remove 
obsolete patch.
---
 gnu/local.mk                                  |  1 -
 .../patches/python-packaging-test-arch.patch  | 65 -------------------
 gnu/packages/python-xyz.scm                   |  7 +-
 3 files changed, 2 insertions(+), 71 deletions(-)
 delete mode 100644 gnu/packages/patches/python-packaging-test-arch.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 891d924ad9..33d49bf26d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1649,7 +1649,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-memcached-syntax-warnings.patch	\
   %D%/packages/patches/python-mox3-python3.6-compat.patch	\
   %D%/packages/patches/python-testtools.patch			\
-  %D%/packages/patches/python-packaging-test-arch.patch		\
   %D%/packages/patches/python2-parameterized-docstring-test.patch	\
   %D%/packages/patches/python-paste-remove-timing-test.patch	\
   %D%/packages/patches/python-pycrypto-CVE-2013-7459.patch	\
diff --git a/gnu/packages/patches/python-packaging-test-arch.patch b/gnu/packages/patches/python-packaging-test-arch.patch
deleted file mode 100644
index df80a62544..0000000000
--- a/gnu/packages/patches/python-packaging-test-arch.patch
+++ /dev/null
@@ -1,65 +0,0 @@ 
-Fix tests that are "hard coded" to expect x86_64 output by mocking the platform interface.
-
-Submitted upstream:
-https://github.com/pypa/packaging/pull/176
-
-diff --git a/tests/test_tags.py b/tests/test_tags.py
-index 1eacf68..0a3f1b4 100644
---- a/tests/test_tags.py
-+++ b/tests/test_tags.py
-@@ -435,37 +435,43 @@ class TestManylinuxPlatform:
-         linux_platform = list(tags._linux_platforms(is_32bit=False))
-         assert linux_platform == ["linux_x86_64"]
- 
--    def test_linux_platforms_manylinux1(self, monkeypatch):
-+    def test_linux_platforms_manylinux1(self, is_x86, monkeypatch):
-         monkeypatch.setattr(
-             tags, "_is_manylinux_compatible", lambda name, _: name == 
"manylinux1"
-         )
--        if platform.system() != "Linux":
-+        if platform.system() != "Linux" or not is_x86:
-             monkeypatch.setattr(distutils.util, "get_platform", lambda: 
"linux_x86_64")
-+            monkeypatch.setattr(platform, "machine", lambda: "x86_64")
-         platforms = list(tags._linux_platforms(is_32bit=False))
--        assert platforms == ["manylinux1_x86_64", "linux_x86_64"]
-+        arch = platform.machine()
-+        assert platforms == ["manylinux1_" + arch, "linux_" + arch]
- 
--    def test_linux_platforms_manylinux2010(self, monkeypatch):
-+    def test_linux_platforms_manylinux2010(self, is_x86, monkeypatch):
-         monkeypatch.setattr(
-             tags, "_is_manylinux_compatible", lambda name, _: name == 
"manylinux2010"
-         )
--        if platform.system() != "Linux":
-+        if platform.system() != "Linux" or not is_x86:
-             monkeypatch.setattr(distutils.util, "get_platform", lambda: 
"linux_x86_64")
-+            monkeypatch.setattr(platform, "machine", lambda: "x86_64")
-         platforms = list(tags._linux_platforms(is_32bit=False))
--        expected = ["manylinux2010_x86_64", "manylinux1_x86_64", "linux_x86_64"]
-+        arch = platform.machine()
-+        expected = ["manylinux2010_" + arch, "manylinux1_" + arch, "linux_" + arch]
-         assert platforms == expected
- 
--    def test_linux_platforms_manylinux2014(self, monkeypatch):
-+    def test_linux_platforms_manylinux2014(self, is_x86, monkeypatch):
-         monkeypatch.setattr(
-             tags, "_is_manylinux_compatible", lambda name, _: name == 
"manylinux2014"
-         )
--        if platform.system() != "Linux":
-+        if platform.system() != "Linux" or not is_x86:
-             monkeypatch.setattr(distutils.util, "get_platform", lambda: 
"linux_x86_64")
-+            monkeypatch.setattr(platform, "machine", lambda: "x86_64")
-         platforms = list(tags._linux_platforms(is_32bit=False))
-+        arch = platform.machine()
-         expected = [
--            "manylinux2014_x86_64",
--            "manylinux2010_x86_64",
--            "manylinux1_x86_64",
--            "linux_x86_64",
-+            "manylinux2014_" + arch,
-+            "manylinux2010_" + arch,
-+            "manylinux1_" + arch,
-+            "linux_" + arch,
-         ]
-         assert platforms == expected
- 
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb96d0a3dc..3ced6f3909 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17905,17 +17905,14 @@  several utilities, as well as an API for building localization tools.")
 (define-public python-packaging
   (package
     (name "python-packaging")
-    (version "20.0")
+    (version "20.9")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "packaging" version))
-        ;; XXX: The URL in the patch file is wrong, it should be
-        ;; <https://github.com/pypa/packaging/pull/256>.
-        (patches (search-patches "python-packaging-test-arch.patch"))
         (sha256
          (base32
-          "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+          "1rgadxvzvhac6wqa512bfj313ww6q3n18i9glzf67j0d6b0plcjv"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-- 
2.31.1