diff mbox series

[bug#70483,v2,1/1] gnu: Add python-robotframework-requests.

Message ID f691c9870d7a6bf09e5ebcfebd0a0de6435b02c5.1713861076.git.markku.korkeala@iki.fi
State New
Headers show
Series [bug#70483,v2,1/1] gnu: Add python-robotframework-requests. | expand

Commit Message

Markku Korkeala April 23, 2024, 8:54 a.m. UTC
* gnu/packages/python-web.scm (python-robotframework-requests): New variable.

Change-Id: I01d814d1a9e20d26e9bfa4a0a77ba91577da2bd8
---
Improved the patch according to feedback:

Moved package to gnu/packages/python-web.scm
Switched to pyproject-build-system
Simplified the test phase
Removed duplicate and unnecessary dependencies
Fixed description identation

 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: ee9cf4f00bcb8966fa125787e8534580b270bb99
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5a532f8460..2d0695d5a4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -64,6 +64,7 @@ 
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2024 normally_js <normally_js@posteo.net>
+;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3763,6 +3764,33 @@  (define-public python-requests-ftp
 adapter for use with the Requests library.")
     (license license:asl2.0)))
 
+(define-public python-robotframework-requests
+  (package
+    (name "python-robotframework-requests")
+    (version "0.9.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MarketSquare/robotframework-requests")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "077j8p5k41v53slyv8h32fcmqfi7m6z3r4gmyqqaawm5szfmy61m"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:test-flags '("-v" "utests/")))
+    (propagated-inputs (list python-requests python-robotframework))
+    (native-inputs (list python-flask python-mock python-pytest
+                         python-pytest-cov))
+    (home-page "https://github.com/MarketSquare/robotframework-requests")
+    (synopsis "Robot Framework keyword library wrapper around requests")
+    (description
+     "RequestsLibrary is a Robot Framework library aimed to provide HTTP
+api testing functionalities by wrapping the well known Python Requests
+Library.")
+    (license license:expat)))
+
 (define-public python-aioftp
   (package
     (name "python-aioftp")