@@ -64,6 +64,7 @@
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 normally_js <normally_js@posteo.net>
+;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3763,6 +3764,33 @@ (define-public python-requests-ftp
adapter for use with the Requests library.")
(license license:asl2.0)))
+(define-public python-robotframework-requests
+ (package
+ (name "python-robotframework-requests")
+ (version "0.9.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MarketSquare/robotframework-requests")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "077j8p5k41v53slyv8h32fcmqfi7m6z3r4gmyqqaawm5szfmy61m"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:test-flags '("-v" "utests/")))
+ (propagated-inputs (list python-requests python-robotframework))
+ (native-inputs (list python-flask python-mock python-pytest
+ python-pytest-cov))
+ (home-page "https://github.com/MarketSquare/robotframework-requests")
+ (synopsis "Robot Framework keyword library wrapper around requests")
+ (description
+ "RequestsLibrary is a Robot Framework library aimed to provide HTTP
+api testing functionalities by wrapping the well known Python Requests
+Library.")
+ (license license:expat)))
+
(define-public python-aioftp
(package
(name "python-aioftp")