diff mbox series

[bug#64044] gnu: mesa: Fix VDPAU drivers path.

Message ID f687c86ace5c768c36212b153d7233d824747923.1686661663.git.glv@posteo.net
State New
Headers show
Series [bug#64044] gnu: mesa: Fix VDPAU drivers path. | expand

Commit Message

Guillaume Le Vaillant June 13, 2023, 1:10 p.m. UTC
The VDPAU_DRIVER_PATH environment variable must contain only one directory.

* gnu/packages/gl.scm (mesa)[native-search-paths]: Fix specification for
  VDPAU_DRIVER_PATH.
---
 gnu/packages/gl.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa

Comments

John Kehayias June 29, 2023, 4:03 p.m. UTC | #1
Hi Guillaume,

On Tue, Jun 13, 2023 at 01:10 PM, Guillaume Le Vaillant wrote:

> The VDPAU_DRIVER_PATH environment variable must contain only one directory.
>
> * gnu/packages/gl.scm (mesa)[native-search-paths]: Fix specification for
>   VDPAU_DRIVER_PATH.
> ---
>  gnu/packages/gl.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 9885bde712..a5b5ade22a 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -517,6 +517,7 @@ (define-public mesa
>       (list (search-path-specification
>              ;; Ensure the Mesa VDPAU drivers can be found.
>              (variable "VDPAU_DRIVER_PATH")
> +            (separator #f)
>              (files '("lib/vdpau")))))
>      (home-page "https://mesa3d.org/")
>      (synopsis "OpenGL and Vulkan implementations")
>
> base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa

Thanks. I'm applying this on a mesa-updates branch which will appear
soon and you can see discussion on guix-devel. My plan is to have this
built with the mesa update (to 23.1.3) and then merge to master.

John
Guillaume Le Vaillant June 30, 2023, 12:42 p.m. UTC | #2
John Kehayias <john.kehayias@protonmail.com> skribis:

> I'm applying this on a mesa-updates branch which will appear
> soon and you can see discussion on guix-devel. My plan is to have this
> built with the mesa update (to 23.1.3) and then merge to master.

Ok, thanks.
John Kehayias July 31, 2023, 3:21 p.m. UTC | #3
On Fri, Jun 30, 2023 at 12:42 PM, Guillaume Le Vaillant wrote:

> John Kehayias <john.kehayias@protonmail.com> skribis:
>
>> I'm applying this on a mesa-updates branch which will appear
>> soon and you can see discussion on guix-devel. My plan is to have this
>> built with the mesa update (to 23.1.3) and then merge to master.
>
> Ok, thanks.

Pushed as c7cf2efb7abcc7a5a7ce9606c9d876d00ddde9ad. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9885bde712..a5b5ade22a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -517,6 +517,7 @@  (define-public mesa
      (list (search-path-specification
             ;; Ensure the Mesa VDPAU drivers can be found.
             (variable "VDPAU_DRIVER_PATH")
+            (separator #f)
             (files '("lib/vdpau")))))
     (home-page "https://mesa3d.org/")
     (synopsis "OpenGL and Vulkan implementations")