diff mbox series

[bug#72219,04/34] gnu: skymaker: Update to 3.10.5.

Message ID f6841eb33eb9bf3e70ba639767ee7e355ea263b5.1721514686.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/07 | expand

Commit Message

Sharlatan Hellseher July 20, 2024, 10:40 p.m. UTC
* gnu/packages/astronomy.scm (skymaker): Update to 3.10.5.

Change-Id: Ib66f35834bdf3d6ce7d1b6924415a3e49b3ae7f9
---
 gnu/packages/astronomy.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bbffe744ab..ae2593e8e4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1467,27 +1467,24 @@  (define-public splash
     (license license:gpl2+)))
 
 (define-public skymaker
-  ;; XXX: No version tag available in GitHub.
-  ;; See: https://github.com/astromatic/skymaker/issues/3
-  (let ((commit "1a69c4716bdc9b5c6d4a917b0bc2dbd47635c459")
-        (revision "0"))
     (package
       (name "skymaker")
-      (version (git-version "4.2.0" revision commit))
+      (version "3.10.5")
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/astromatic/skymaker")
-               (commit commit)))
+               (commit version)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1vin4vgvcmqmwjdchsxnap374559rksz55xmaliawnl3qpzxn1nk"))))
+          (base32 "0kcy0lfm25gihahpr41ghhw3b8znzczzg9rrlkfih043h2pfsm5l"))))
       (build-system gnu-build-system)
       (arguments
        (list
         #:configure-flags
         #~(list
+           "CPPFLAGS=-fcommon"
            (string-append
             "--with-fftw-libdir=" #$(this-package-input "fftwf") "/lib")
            (string-append
@@ -1503,7 +1500,7 @@  (define-public skymaker
 object lists in ASCII generated by the Stuff program to produce realistic
 astronomical fields.  SkyMaker is part of the
 @uref{https://www.astromatic.net/projects/efigi, EFIGI} development project.")
-      (license license:gpl3+))))
+      (license license:gpl3+)))
 
 (define-public stackistry
   (package