diff mbox series

[bug#37717,2/3] gnu: Add ghc-unagi-chan.

Message ID f66552cb-b5f2-4288-a366-bfd077e8bba4@www.fastmail.com
State Accepted
Headers show
Series gnu: Add kmonad. | expand

Commit Message

Alex Griffin Oct. 12, 2019, 7:34 p.m. UTC

Comments

Marius Bakke Oct. 18, 2019, 6:28 p.m. UTC | #1
"Alex Griffin" <a@ajgrf.com> writes:

> From 12b43fc165aafce2844f8edf9dad99f89bcad943 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sat, 12 Oct 2019 13:45:35 -0500
> Subject: [PATCH 2/3] gnu: Add ghc-unagi-chan.
>
> * gnu/packages/haskell-xyz.scm (ghc-unagi-chan): New variable.

[...]

> +(define-public ghc-unagi-chan
> +  (package
> +    (name "ghc-unagi-chan")
> +    (version "0.4.1.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://hackage.haskell.org/package/unagi-chan/unagi-chan-"
> +             version
> +             ".tar.gz"))

I did not find this package in Stackage 12.26, so I guess it's OK to
take this one.  It's nice if you can prettify these lines, though :-)

> +       (sha256
> +        (base32
> +         "1lnl5n4jnjmm4chp461glcwkrrw63rjz3fvprwxcy3lkpbkrqvgn"))))
> +    (build-system haskell-build-system)
> +    (inputs
> +     `(("ghc-atomic-primops" ,ghc-atomic-primops)
> +       ("ghc-primitive" ,ghc-primitive)))
> +    (arguments
> +     `(#:tests? #f ; FIXME: Tests can't find Data.Primitive.Addr

Should this not be provided by 'ghc-primitive'?  Perhaps it is expecting
a different version?
diff mbox series

Patch

From 12b43fc165aafce2844f8edf9dad99f89bcad943 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sat, 12 Oct 2019 13:45:35 -0500
Subject: [PATCH 2/3] gnu: Add ghc-unagi-chan.

* gnu/packages/haskell-xyz.scm (ghc-unagi-chan): New variable.
---
 gnu/packages/haskell-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 37df2ed909..e8a6a1c498 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10631,6 +10631,39 @@  processes.  It wraps around the @code{process} library, and intends to improve
 upon it.")
     (license license:expat)))
 
+(define-public ghc-unagi-chan
+  (package
+    (name "ghc-unagi-chan")
+    (version "0.4.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/unagi-chan/unagi-chan-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1lnl5n4jnjmm4chp461glcwkrrw63rjz3fvprwxcy3lkpbkrqvgn"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-atomic-primops" ,ghc-atomic-primops)
+       ("ghc-primitive" ,ghc-primitive)))
+    (arguments
+     `(#:tests? #f ; FIXME: Tests can't find Data.Primitive.Addr
+       #:cabal-revision
+       ("1"
+        "09pqi867wskwgc5lpn197f895mbn1174ydgllvcppcsmrz2b6yr6")))
+    (home-page "http://hackage.haskell.org/package/unagi-chan")
+    (synopsis "Fast concurrent queues with a Chan-like API, and more")
+    (description
+     "This library provides implementations of concurrent FIFO queues (for
+both general boxed and primitive unboxed values) that are fast, perform well
+under contention, and offer a Chan-like interface.  The library may be of
+limited usefulness outside of x86 architectures where the fetch-and-add
+instruction is not available.")
+    (license license:bsd-3)))
+
 (define-public ghc-unbounded-delays
   (package
     (name "ghc-unbounded-delays")
-- 
2.23.0