diff mbox series

[bug#61989,04/11] gnu: Add go-github-com-aperturerobotics-jacobsa-crypto.

Message ID f60ccaf5e7a5a4439ea2fd1c53272028b6bb101e.1678049134.git.felix.lechner@lease-up.com
State New
Headers show
Series Adding Gocryptfs (feature branch) | expand

Commit Message

Felix Lechner March 5, 2023, 8:54 p.m. UTC
* gnu/packages/golang.scm (go-github-com-aperturerobotics-jacobsa-crypto): New variable.
---
 gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 608b08ba29..312a314e39 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1186,6 +1186,37 @@  (define-public go-github-com-hanwen-go-fuse-v2
        "This is a repository containing Go bindings for writing FUSE file systems.")
       (license license:bsd-3))))
 
+(define-public go-github-com-aperturerobotics-jacobsa-crypto
+  (let ((commit "b1eb679742a8deed015a4406384eea6bd985d08a")
+        (revision "0"))
+    (package
+      (name "go-github-com-aperturerobotics-jacobsa-crypto")
+      (version (git-version "1.0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/aperturerobotics/jacobsa-crypto")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "16dxigj8m6q18xqsy72iq287rh4fw0y0b9yqlw0qkclb8379n1z2"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/aperturerobotics/jacobsa-crypto"
+             ;; Source-only package.
+             #:tests? #f
+             #:phases
+             #~(modify-phases %standard-phases
+                 ;; Source-only package.
+                 (delete 'build))))
+      (home-page "https://github.com/aperturerobotics/jacobsa-crypto")
+      (synopsis "Cryptography missing from the Go standard library")
+      (description
+       "This repository contains Go packages related to cryptographic standards that are
+not included in the Go standard library.")
+      (license license:asl2.0))))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")