diff mbox series

[bug#69764] gnu: python-build: Update python-wheel to 0.43.0.

Message ID f5a3f26fb824e9323dd037420f4d30f9@lyrion.ch
State New
Headers show
Series [bug#69764] gnu: python-build: Update python-wheel to 0.43.0. | expand

Commit Message

Daniel Ziltener March 12, 2024, 11:47 p.m. UTC
---
 gnu/packages/python-build.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 2ea457cdba..863ed7373a 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -331,20 +331,17 @@  (define-public python-setuptools-57
 (define-public python-wheel
   (package
     (name "python-wheel")
-    (version "0.40.0")
+    (version "0.43.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "wheel" version))
         (sha256
          (base32
-          "0ww8fgkvwv35ypj4cnngczdwp6agr4qifvk2inb32azfzbrrc4fd"))))
-    (build-system python-build-system)
-    (arguments
-     ;; FIXME: The test suite runs "python setup.py bdist_wheel", which in turn
-     ;; fails to find the newly-built bdist_wheel library, even though it is
-     ;; available on PYTHONPATH.  What search path is consulted by setup.py?
-     '(#:tests? #f))
+          "118x5y37152by7f8gvzwda441jd8b42w92ngs6i5sp7sd4ngjpj6"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-flit-core))
     (home-page "https://github.com/pypa/wheel")
     (synopsis "Format for built Python packages")
     (description