diff mbox series

[bug#42958] Big changes from wip-desktop.

Message ID f58d0875-cb71-1deb-bb29-f414f71ffc81@raghavgururajan.name
State Accepted
Headers show
Series [bug#42958] Big changes from wip-desktop. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 26, 2021, 8:12 p.m. UTC
@(rekado|lle-bout|danny)

>> Could any of you please review and merge the attached patches to 
>> core-updates?
>>
>> These patches has been successfully built on bayfront, from which you 
>> can obtain substitutes, if needed.
>>
>> I will send some more patches for this #42958 by tomorrow.
>>
>> It would be great if we could together finish-off this #42958 ASAP, so 
>> that I can bring remaining patches from wip-deskop.
>>
>> P.S
>> Please pardon two cosmetic changes patches, which were done very long 
>> ago and had to use it to cleanly apply succeeding patches. Also, I 
>> must have used #t with lambda out of habit.
> 
> Since there was master <--> core-updates merge, here I have attached 
> rebased patches. Thanks to Léo Le Bouter.

So I have attached all the patches for this batch. These are 
non-signed-off, just for the record. :)

Regards,
RG.
diff mbox series

Patch

From 730f60b68f50e562cecea119338f8736d1f9f8bc Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 18 Jul 2020 06:18:38 -0400
Subject: [PATCH 83/83] gnu: gtkmm-2: Fix build.

* gnu/packages/gtk.scm (gtkmm-2)[arguments]: Remove field.
[native-inputs]: Remove field.
[propagated-inputs]: Change; atkmm to atkmm-2.28, pangomm to pangomm-2.42,
cairomm to cairomm-1.13 and glibmm to glibmm-2.64.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
---
 gnu/packages/gtk.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5da8954dc9..517264d88b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1654,25 +1654,25 @@  tutorial.")
       license:gpl2+))))
 
 (define-public gtkmm-2
-  (package (inherit gtkmm)
+  (package
+    (inherit gtkmm)
     (name "gtkmm")
     (version "2.24.5")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnome/sources/" name "/"
-                                 (version-major+minor version)  "/"
-                                 name "-" version ".tar.xz"))
-             (sha256
-              (base32
-               "0wkbzvsx4kgw16f6xjdc1dz7f77ldngdila4yi5lw2zrgcxsb006"))))
-    (arguments '())
-    (native-inputs `(("pkg-config" ,pkg-config)))
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://gnome/sources/" name "/"
+                       (version-major+minor version)  "/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0wkbzvsx4kgw16f6xjdc1dz7f77ldngdila4yi5lw2zrgcxsb006"))))
     (propagated-inputs
-     `(("pangomm" ,pangomm)
-       ("cairomm" ,cairomm)
-       ("atkmm" ,atkmm)
+     `(("atkmm" ,atkmm-2.28)
+       ("cairomm" ,cairomm-1.13)
+       ("glibmm" ,glibmm-2.64)
        ("gtk+" ,gtk+-2)
-       ("glibmm" ,glibmm)))))
+       ("pangomm" ,pangomm-2.42)))))
 
 (define-public gtksourceviewmm
   (package
-- 
2.31.0