diff mbox series

[bug#72594,7/7] gnu: Add go-github-com-containerd-typeurl-v2.

Message ID f562ec4eeca20a1d44d31c407b1cc5d525c3788d.1723483365.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some of the Google gvisor dependencies. | expand

Commit Message

Artyom V. Poptsov Aug. 12, 2024, 5:26 p.m. UTC
* gnu/packages/golang.scm (go-github-com-containerd-typeurl-v2): New variable.

Change-Id: I2468cff298ef8b73ddbf24cccb86a1a85ca67a15
---
 gnu/packages/golang.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dd16e374ff..8734e5f677 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7955,6 +7955,25 @@  (define-public go-github-com-containerd-typeurl
 Any}.")
     (license license:asl2.0)))
 
+(define-public go-github-com-containerd-typeurl-v2
+  (package
+    (inherit go-github-com-containerd-typeurl)
+    (name "go-github-com-containerd-typeurl-v2")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/containerd/typeurl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n43s8zqwwrvpzb0pczm73xx4w8yb96ax31cripzxmfhj43z21b5"))))
+    (arguments
+     (list #:import-path "github.com/containerd/typeurl/v2"))
+    (propagated-inputs (list go-github-com-gogo-protobuf
+                             go-google-golang-org-protobuf))))
+
 (define-public go-github-com-arceliar-ironwood
   (package
     (name "go-github-com-arceliar-ironwood")