[bug#75573] gnu: Add fatresize.
Commit Message
* gnu/packages/disk.scm (fatresize): New variable.
Change-Id: Iebe5d4df7e3c8b4d41f72d5774577672c9c6ba9b
---
gnu/packages/disk.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
base-commit: bde32a3d88482f6e0b2f260174914c020a7c6166
Comments
Sughosha <sughosha@disroot.org> writes:
> * gnu/packages/disk.scm (fatresize): New variable.
Pushed to master, thank you!
@@ -595,6 +595,29 @@ (define-public fatfsck/static
and a @command{fsck.vfat} compatibility symlink for use in an initrd.")
(license (package-license dosfstools))))
+(define-public fatresize
+ (package
+ (name "fatresize")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ya-mouse/fatresize")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1vhz84kxfyl0q7mkqn68nvzzly0a4xgzv76m6db0bk7xyczv1qr2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list parted))
+ (home-page "https://github.com/ya-mouse/fatresize")
+ (synopsis "Tool to resize FAT partitions using libparted")
+ (description
+ "This package provides a tool to resize FAT partitions using libparted")
+ (license license:gpl3+)))
+
(define-public hdparm
(package
(name "hdparm")