diff mbox series

[bug#69652,gnome-team,1/1] gnu: orbit2: Mark it unsupported in 32-bits systems.

Message ID f4d66a6dd79c865b94a50523f6c4464399e13389.1709918975.git.vivien@planete-kraus.eu
State New
Headers show
Series What should we do with orbit2? | expand

Commit Message

Vivien Kraus March 8, 2024, 5:20 p.m. UTC
* gnu/packages/gnome.scm (orbit2) [supported-systems]: New field.
[arguments]: Convert to list of G-Expressions.

Change-Id: I55766c43e7abc703815c30dccf38faf640ffc07e
---
 gnu/packages/gnome.scm | 53 ++++++++++++++++++++++--------------------
 1 file changed, 28 insertions(+), 25 deletions(-)

Comments

Liliana Marie Prikler March 8, 2024, 7:11 p.m. UTC | #1
Am Freitag, dem 08.03.2024 um 18:20 +0100 schrieb Vivien Kraus:
> * gnu/packages/gnome.scm (orbit2) [supported-systems]: New field.
> [arguments]: Convert to list of G-Expressions.
> 
> Change-Id: I55766c43e7abc703815c30dccf38faf640ffc07e
> ---
>  gnu/packages/gnome.scm | 53 ++++++++++++++++++++++------------------
> --
>  1 file changed, 28 insertions(+), 25 deletions(-)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 13cad0add2..711890d617 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3798,34 +3798,37 @@ (define-public orbit2
>                (sha256
>                 (base32
>                 
> "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
> +    ;; Many tests fail on 32-bit systems.
> +    (supported-systems %64bit-supported-systems)
Prefer the “disable-failing-tests” pattern, but first investigate why
they fail.  Note that this would make icecat and icedove 64-bit only
(that is if Rust doesn't do so already).
>      (build-system gnu-build-system)
>      (arguments
> -     `(;; The "timeout-server" test hangs when run in parallel.
> -       #:parallel-tests? #f
> -       #:configure-flags
> -       '(;; We don't need static libraries, plus they don't build
> reproducibly
> -         ;; (non-deterministic ordering of .o files in the archive.)
> -         "--disable-static"
> -
> -         ;; The programmer kindly gives us a hook to turn off
> deprecation
> -         ;; warnings ...
> -         "DISABLE_DEPRECATED_CFLAGS=-
> DGLIB_DISABLE_DEPRECATION_WARNINGS")
> -       ;; ... which they then completly ignore !!
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'fix-parallel-build
> -           ;; Parallel build fails because of a failed dependency,
> -           ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
> -           (lambda _
> -             (substitute* "src/services/name/Makefile.am"
> -               (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS)
> CosNaming.h")
> -                "orbit_name_server_2_DEPENDENCIES = \
> +     (list
> +      ;; The "timeout-server" test hangs when run in parallel.
> +      #:parallel-tests? #f
> +      #:configure-flags
> +      #~'(;; We don't need static libraries, plus they don't build
> reproducibly
> +          ;; (non-deterministic ordering of .o files in the
> archive.)
> +          "--disable-static"
> +
> +          ;; The programmer kindly gives us a hook to turn off
> deprecation
> +          ;; warnings ...
> +          "DISABLE_DEPRECATED_CFLAGS=-
> DGLIB_DISABLE_DEPRECATION_WARNINGS")
> +      ;; ... which they then completly ignore !!
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'fix-parallel-build
> +            ;; Parallel build fails because of a failed dependency,
> +            ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
> +            (lambda _
> +              (substitute* "src/services/name/Makefile.am"
> +                (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS)
> CosNaming.h")
> +                 "orbit_name_server_2_DEPENDENCIES = \
>  $(DEPS) CosNaming.h libname-server-2.a"))))
> -         (add-before 'configure 'ignore-deprecations
> -           (lambda _
> -             (substitute* "linc2/src/Makefile.in"
> -               (("-DG_DISABLE_DEPRECATED")
> -                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> +          (add-before 'configure 'ignore-deprecations
> +            (lambda _
> +              (substitute* "linc2/src/Makefile.in"
> +                (("-DG_DISABLE_DEPRECATED")
> +                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
What changes in this hunk?

Cheers
Vivien Kraus March 8, 2024, 8:03 p.m. UTC | #2
Le vendredi 08 mars 2024 à 20:11 +0100, Liliana Marie Prikler a écrit :
> Prefer the “disable-failing-tests” pattern, but first investigate why
> they fail.  Note that this would make icecat and icedove 64-bit only
> (that is if Rust doesn't do so already).

Rust has already been introduced in both.

> >  $(DEPS) CosNaming.h libname-server-2.a"))))
> > -         (add-before 'configure 'ignore-deprecations
> > -           (lambda _
> > -             (substitute* "linc2/src/Makefile.in"
> > -               (("-DG_DISABLE_DEPRECATED")
> > -                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > +          (add-before 'configure 'ignore-deprecations
> > +            (lambda _
> > +              (substitute* "linc2/src/Makefile.in"
> > +                (("-DG_DISABLE_DEPRECATED")
> > +                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> What changes in this hunk?
> 
It’s hard to see, but the indentation changed.  Should it be ignored?
Liliana Marie Prikler March 9, 2024, 6:36 a.m. UTC | #3
Am Freitag, dem 08.03.2024 um 21:03 +0100 schrieb Vivien Kraus:
> Le vendredi 08 mars 2024 à 20:11 +0100, Liliana Marie Prikler a
> écrit :
> > Prefer the “disable-failing-tests” pattern, but first investigate
> > why they fail.  Note that this would make icecat and icedove 64-bit
> > only (that is if Rust doesn't do so already).
> 
> Rust has already been introduced in both.
I'd still like to avoid overconstraining if possible.

> > >  $(DEPS) CosNaming.h libname-server-2.a"))))
> > > -         (add-before 'configure 'ignore-deprecations
> > > -           (lambda _
> > > -             (substitute* "linc2/src/Makefile.in"
> > > -               (("-DG_DISABLE_DEPRECATED")
> > > -                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > > +          (add-before 'configure 'ignore-deprecations
> > > +            (lambda _
> > > +              (substitute* "linc2/src/Makefile.in"
> > > +                (("-DG_DISABLE_DEPRECATED")
> > > +                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
> > What changes in this hunk?
> > 
> It’s hard to see, but the indentation changed.  Should it be ignored?
Rather, the cosmetic change should be separated from the semantic
change.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 13cad0add2..711890d617 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3798,34 +3798,37 @@  (define-public orbit2
               (sha256
                (base32
                 "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
+    ;; Many tests fail on 32-bit systems.
+    (supported-systems %64bit-supported-systems)
     (build-system gnu-build-system)
     (arguments
-     `(;; The "timeout-server" test hangs when run in parallel.
-       #:parallel-tests? #f
-       #:configure-flags
-       '(;; We don't need static libraries, plus they don't build reproducibly
-         ;; (non-deterministic ordering of .o files in the archive.)
-         "--disable-static"
-
-         ;; The programmer kindly gives us a hook to turn off deprecation
-         ;; warnings ...
-         "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
-       ;; ... which they then completly ignore !!
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-parallel-build
-           ;; Parallel build fails because of a failed dependency,
-           ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
-           (lambda _
-             (substitute* "src/services/name/Makefile.am"
-               (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
-                "orbit_name_server_2_DEPENDENCIES = \
+     (list
+      ;; The "timeout-server" test hangs when run in parallel.
+      #:parallel-tests? #f
+      #:configure-flags
+      #~'(;; We don't need static libraries, plus they don't build reproducibly
+          ;; (non-deterministic ordering of .o files in the archive.)
+          "--disable-static"
+
+          ;; The programmer kindly gives us a hook to turn off deprecation
+          ;; warnings ...
+          "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+      ;; ... which they then completly ignore !!
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-parallel-build
+            ;; Parallel build fails because of a failed dependency,
+            ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
+            (lambda _
+              (substitute* "src/services/name/Makefile.am"
+                (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
+                 "orbit_name_server_2_DEPENDENCIES = \
 $(DEPS) CosNaming.h libname-server-2.a"))))
-         (add-before 'configure 'ignore-deprecations
-           (lambda _
-             (substitute* "linc2/src/Makefile.in"
-               (("-DG_DISABLE_DEPRECATED")
-                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
+          (add-before 'configure 'ignore-deprecations
+            (lambda _
+              (substitute* "linc2/src/Makefile.in"
+                (("-DG_DISABLE_DEPRECATED")
+                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
     (inputs (list glib libidl))
     (native-inputs
      (list pkg-config))