[bug#76746,v2,11/13] gnu: Add python-pytube.

Message ID f4d5f3d62a88b1120c5dc82eff6d18c981921e75.1741702573.git.45mg.writes@gmail.com
State New
Headers
Series None |

Commit Message

45mg March 11, 2025, 2:23 p.m. UTC
  * gnu/packages/python-web.scm (python-pytube): New variable.

Change-Id: Ie2b342a884b4694a0dc8a0c959a918e4b0ab25b3
---
 gnu/packages/python-web.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cc8362327f..5355eaa3fe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -10771,6 +10771,36 @@  (define-public python-ytmusicapi
 authentication.")
     (license license:expat)))
 
+(define-public python-pytube
+  (package
+    (name "python-pytube")
+    (version "15.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pytube/pytube")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        "1598764vnzhc5s4w1car5sci3fmf8lp3rflsysb76f794ms35vvd")))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest python-setuptools python-wheel))
+    (arguments
+     '(#:test-flags  ;Disable network-dependent tests.
+       '("--ignore=tests/test_extract.py"
+         "--ignore=tests/test_query.py"
+         "--ignore=tests/test_streams.py"
+         "--ignore=tests/test_main.py"
+         "-k"
+         "not test_streaming")))
+    (home-page "https://github.com/pytube/pytube")
+    (synopsis "Library and utility for downloading YouTube videos")
+    (description
+     "This is a lightweight, dependency-free Python 3 library (and
+command-line utility) for downloading YouTube videos.")
+    (license license:unlicense)))
+
 (define-public python-whatthepatch
   (package
     (name "python-whatthepatch")