diff mbox series

[bug#60642,staging] gnu: glew: Update to 2.2.0.

Message ID f46d6c545ac9ad8c53c66235c9c28ca77794c61a.1673150797.git.poomklao@yahoo.com
State New
Headers show
Series [bug#60642,staging] gnu: glew: Update to 2.2.0. | expand

Commit Message

Parnikkapore Jan. 8, 2023, 4:06 a.m. UTC
* gnu/packages/gl.scm (glew): Update to 2.2.0.
  [source] Migrato to GitHub, which is now the canonical source
  [home-page] Use HTTPS
---
 gnu/packages/gl.scm | 35 ++++++++++++++++++++---------------
 1 file changed, 20 insertions(+), 15 deletions(-)


base-commit: db3fdbbdfee9d412053cc9538ad76abee7c2cb89

Comments

宋文武 Jan. 29, 2023, 7:56 a.m. UTC | #1
Parnikkapore <poomklao@yahoo.com> writes:

> * gnu/packages/gl.scm (glew): Update to 2.2.0.

Hello, on the staging branch glew is 2.2.0 already, close this, thank
you!
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01ab6135a4..136b0bdf2f 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -616,36 +616,41 @@  (define-public mesa-utils
 (define-public glew
   (package
     (name "glew")
-    (version "2.1.0")
+    (version "2.2.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://sourceforge/glew/glew/" version
-                                  "/glew-" version ".tgz"))
+              (uri (string-append
+                    "https://github.com/nigels-com/glew/releases"
+                    "/download/glew-"
+                    version
+                    "/glew-"
+                    version
+                    ".tgz"))
               (sha256
                (base32
-                "159wk5dc0ykjbxvag5i1m2mhp23zkk6ra04l26y3jc3nwvkr3ph4"))
+                "1qak8f7g1iswgswrgkzc7idk7jmqgwrs58fhg2ai007v7j4q5z6l"))
               (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (substitute* "config/Makefile.linux"
-                    (("= cc") "= gcc")
-                    (("/lib64") "/lib"))
-                  #t))))
+              (snippet '(begin
+                          (substitute* "config/Makefile.linux"
+                            (("= cc")
+                             "= gcc")
+                            (("/lib64")
+                             "/lib")) #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
+     '(#:phases (modify-phases %standard-phases
+                  (delete 'configure))
        #:make-flags (list (string-append "GLEW_PREFIX="
                                          (assoc-ref %outputs "out"))
                           (string-append "GLEW_DEST="
                                          (assoc-ref %outputs "out")))
-       #:tests? #f))                              ;no 'check' target
-    (inputs
-     (list libxi libxmu libx11 mesa))
+       #:tests? #f)) ;no 'check' target
+    (inputs (list libxi libxmu libx11 mesa))
 
     ;; <GL/glew.h> includes <GL/glu.h>.
     (propagated-inputs (list glu))
 
-    (home-page "http://glew.sourceforge.net/")
+    (home-page "https://glew.sourceforge.net/")
     (synopsis "OpenGL extension loading library for C and C++")
     (description
      "The OpenGL Extension Wrangler Library (GLEW) is a C/C++ extension