diff mbox series

[bug#57419] gnu: add python-grid5000

Message ID f4490ba376b8366d083f9be956d23e4fdea60e89.1661459445.git.matthieu.simonin@inria.fr
State Accepted
Headers show
Series [bug#57419] gnu: add python-grid5000 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

matthieu.simonin@inria.fr Aug. 25, 2022, 8:30 p.m. UTC
From: msimonin <matthieu.simonin@inria.fr>

---
 gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 26ff8a4b733c06b4f38aa1fb1ec6705bf30eae4a

Comments

Marius Bakke Aug. 29, 2022, 4:09 p.m. UTC | #1
Hi Matthieu,

Welcome to Guix!  The patch looks good overall, a few minor questions:

> +(define-public python-grid5000
> +  (package
> +    (name "python-grid5000")
> +    (version "1.2.3")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://gitlab.inria.fr/msimonin/python-grid5000")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               "097pm8b68ihk29xz9zv29b1x0bhgjb4lfj8zxk2grbsh7wr9dipg")))
> +    (build-system python-build-system)
> +    (native-inputs (list python-wheel))
> +    (propagated-inputs (list python-requests python-ipython python-pyyaml))
> +    (arguments
> +     (list #:tests? #f))

Can you add a comment stating why tests are disabled?

> +    (home-page "https://pypi.org/project/python-grid5000/")
> +    (synopsis "Grid5000 python client")
> +    (description
> +     "python-grid5000 is a python package wrapping the Grid5000 REST API.
> +    You can use it as a library in your python project or you can
> +    explore the Grid5000 resources interactively using the embedded shell.")
> +    (license license:gpl3)))

The LICENSE.txt file says LGPL3, setup.cfg says GPL3.  Which is
correct?  :-)

Also, unless otherwise noted in the source code (e.g. "version 3 only"),
it should be "gpl3+", i.e. "and any later version".

Can you send an updated patch?

Thanks in advance!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d060d5b27c..2fea8cfcb0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7786,3 +7786,28 @@  (define-public python-whatthepatch
     (description
      "This package provides a library to parse and apply patches.")
     (license license:expat)))
+
+(define-public python-grid5000
+  (package
+    (name "python-grid5000")
+    (version "1.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.inria.fr/msimonin/python-grid5000")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               "097pm8b68ihk29xz9zv29b1x0bhgjb4lfj8zxk2grbsh7wr9dipg")))
+    (build-system python-build-system)
+    (native-inputs (list python-wheel))
+    (propagated-inputs (list python-requests python-ipython python-pyyaml))
+    (arguments
+     (list #:tests? #f))
+    (home-page "https://pypi.org/project/python-grid5000/")
+    (synopsis "Grid5000 python client")
+    (description
+     "python-grid5000 is a python package wrapping the Grid5000 REST API.
+    You can use it as a library in your python project or you can
+    explore the Grid5000 resources interactively using the embedded shell.")
+    (license license:gpl3)))