diff mbox series

[bug#49432] gnu: gccgo: Override empty GOROOT/GCCGOTOOLDIR

Message ID f3e624c4092f65a31d36bf5b8ecc0f04f1fe4a45.1625556128.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#49432] gnu: gccgo: Override empty GOROOT/GCCGOTOOLDIR | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 6, 2021, 7:30 a.m. UTC
gnu/packages/gcc.scm (make-gccgo)[arguments]: Set tool paths
(GOROOT and GCCGOTOOLDIR) even if they are already set to "".
---
Hello all,

It turns out some tools use

  GOROOT='' go env GOROOT

to find Go, which was breaking with Gccgo. This little patch fixes that.

As for the commit title, I wasn't sure if "gnu: gccgo" or "gnu: make-gccgo"
was more appropriate here... there aren't a lot of examples in the commit log!

Thanks,
Sarah

 gnu/packages/gcc.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: aa6e6fb2e9ea231d12d49a8925fddd8d2686ea94

Comments

Efraim Flashner Dec. 7, 2021, 1:27 p.m. UTC | #1
Looks like this got dropped somewhere. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 2fe30b1321..02d6824a99 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -871,9 +871,9 @@  provides the GNU compiler for the Go programming language.")
                         (tooldir (dirname (car (find-files exedir "^cgo$")))))
                    (wrap-program (string-append out "/bin/go")
                      `("GCCGOTOOLDIR" =
-                       (,(string-append "${GCCGOTOOLDIR-" tooldir "}")))
+                       (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
                      `("GOROOT" =
-                       (,(string-append "${GOROOT-" out "}")))))))
+                       (,(string-append "${GOROOT:-" out "}")))))))
              (add-before 'configure 'fix-gotools-runpath
                (lambda _
                  (substitute* "gotools/Makefile.in"