@@ -1287,6 +1287,7 @@ dist_patch_DATA = \
%D%/packages/patches/fulcrum-1.9.1-unbundled-libraries.patch \
%D%/packages/patches/fuse-glibc-2.34.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
+ %D%/packages/patches/fuzzel-fix-gcc-error.patch \
%D%/packages/patches/fuzzylite-relative-path-in-tests.patch \
%D%/packages/patches/fuzzylite-use-catch2.patch \
%D%/packages/patches/fuzzylite-soften-float-equality.patch \
new file mode 100644
@@ -0,0 +1,42 @@
+From 05b16745a1d26c4e098c39a49c56e9c312771bd2 Mon Sep 17 00:00:00 2001
+From: Ashish SHUKLA <ashish.is@lostca.se>
+Date: Mon, 23 Sep 2024 12:43:37 +0200
+Subject: [PATCH] Fix release build with GCC 11.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+meson in release build mode (with GCC) triggers following compiler error:
+
+ In file included from ../source/clipboard.c:14:
+ ../source/clipboard.c: In function ‘select_mime_type_for_offer’:
+ ../source/log.h:58:5: error: ‘%s’ directive argument is null [-Werror=format-overflow=]
+ 58 | log_msg(LOG_CLASS_DEBUG, LOG_MODULE, __FILE__, __LINE__, fmt, ## __VA_ARGS__)
+ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ ../source/clipboard.c:81:5: note: in expansion of macro ‘LOG_DBG’
+ 81 | LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+ | ^~~~~~~
+ ../source/clipboard.c:81:31: note: format string is defined here
+ 81 | LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+ | ^~
+
+Fixes #420
+---
+ clipboard.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/clipboard.c b/clipboard.c
+index a4fa2d2..c692503 100644
+--- a/clipboard.c
++++ b/clipboard.c
+@@ -79,7 +79,9 @@ select_mime_type_for_offer(const char *_mime_type,
+ }
+
+ LOG_DBG("mime-type: %s -> %s (offered type was %s)",
+- mime_type_map[*type], mime_type_map[mime_type], _mime_type);
++ mime_type_map[*type],
++ (mime_type_map[mime_type] == NULL ? "(null)" : mime_type_map[mime_type]),
++ _mime_type);
+
+ /* Mime-type transition; if the new mime-type is "better" than
+ * previously offered types, use the new type */
@@ -3424,7 +3424,7 @@ (define-public j4-dmenu-desktop
(define-public fuzzel
(package
(name "fuzzel")
- (version "1.10.2")
+ (version "1.11.0")
(home-page "https://codeberg.org/dnkl/fuzzel")
(source (origin
(method git-fetch)
@@ -3432,7 +3432,9 @@ (define-public fuzzel
(file-name (git-file-name name version))
(sha256
(base32
- "024gnddvabf5dwkdffr6qnnia810w1jqn4ll9fvbcaimybgpvs13"))))
+ "1z4n1i9rdhfcmfsvb5bvsqy8x8fg51kfiakyqnp200n1nl0kd9ll"))
+ (patches
+ (search-patches "fuzzel-fix-gcc-error.patch"))))
(build-system meson-build-system)
(arguments
(list #:build-type "release"
From: Ashish SHUKLA <ashish.is@lostca.se> * gnu/packages/xdisorg.scm (fuzzel): Update to 1.11.0. [sources](origin)<patches>: Add patch. * gnu/packages/patches/fuzzel-fix-gcc-error.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Change-Id: I7ed41e6b23657833369f9d319c22421161559dc7 --- The attached patch fixes a build error, and is submitted upstream[0] References: [0] https://codeberg.org/dnkl/fuzzel/pulls/421 Thanks! Ashish gnu/local.mk | 1 + .../patches/fuzzel-fix-gcc-error.patch | 42 +++++++++++++++++++ gnu/packages/xdisorg.scm | 6 ++- 3 files changed, 47 insertions(+), 2 deletions(-) create mode 100644 gnu/packages/patches/fuzzel-fix-gcc-error.patch base-commit: 039635567d17460d8d541caa58897db83a3565a8