[bug#75797,core-packages-team] gnu: libseccomp: Update to 2.6.0.

Message ID f3ceaf83930f4402b1650e3bab0bac85f56cef3d.1737700288.git.zhengjunjie@iscas.ac.cn
State New
Headers
Series [bug#75797,core-packages-team] gnu: libseccomp: Update to 2.6.0. |

Commit Message

Zheng Junjie Jan. 24, 2025, 6:31 a.m. UTC
  * gnu/packages/linux.scm (libseccomp): Update to 2.6.0.
[source]: Switch to git-fetch.
[arguments]: Use G-expressions.
[native-inputs]: Add autoconf, automake, and libtool.

Change-Id: I19302252578c6791937ec073d24607e19277f49a
---
 gnu/packages/linux.scm | 30 ++++++++++++++++--------------
 1 file changed, 16 insertions(+), 14 deletions(-)


base-commit: 3cf48f590c53651e0073a90cf2a5d51098c667af
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1f62c63f08..5a6c41a426 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7753,26 +7753,28 @@  (define-public mtd-utils
 (define-public libseccomp
   (package
     (name "libseccomp")
-    (version "2.5.4")
+    (version "2.6.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/seccomp/libseccomp/"
-                                  "releases/download/v" version
-                                  "/libseccomp-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/seccomp/libseccomp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1nyb3lspc5bsirpsx89vah3n54pmwlgxrwsfaxl01kq50i004afq"))))
+                "189yh66aj3z3jvns739qbj504f3mcl3w44pxxizw877pbj3kal11"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags '("--disable-static")
-       #:phases (modify-phases %standard-phases
-                  (add-before 'check 'skip-load-test
-                    (lambda _
-                      ;; This test does a native system call and fails when
-                      ;; run under QEMU user-mode emulation.  Just skip it.
-                      (delete-file "tests/52-basic-load.tests"))))))
+     (list
+      #:configure-flags #~(list "--disable-static")
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'skip-load-test
+                     (lambda _
+                       ;; This test does a native system call and fails when
+                       ;; run under QEMU user-mode emulation.  Just skip it.
+                       (delete-file "tests/52-basic-load.tests"))))))
     (native-inputs
-     (list gperf which))
+     (list autoconf automake gperf libtool which))
     (synopsis "Interface to Linux's seccomp syscall filtering mechanism")
     (description "The libseccomp library provides an easy to use, platform
 independent, interface to the Linux Kernel's syscall filtering mechanism.  The