diff mbox series

[bug#60995,v3,1/1] gnu: Add obs-vkcapture.

Message ID f3a38c28c2d8fc655998a029306f4dbd5646e582.1674340347.git.oj@vern.cc
State New
Headers show
Series Thanks for the help | expand

Commit Message

Ott Jan. 21, 2023, 10:33 p.m. UTC
From: Ott Joon <oj@vern.cc>

* gnu/packages/video.scm (obs-vkcapture): New variable.

gnu: Add obs-vkcapture

* gnu/packages/video.scm (obs-vkcapture): New variable.
---
 gnu/packages/video.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Andrew Tropin Feb. 1, 2023, 8:55 a.m. UTC | #1
On 2023-01-22 00:33, Ott via Guix-patches via wrote:

> From: Ott Joon <oj@vern.cc>
>
> * gnu/packages/video.scm (obs-vkcapture): New variable.
>
> gnu: Add obs-vkcapture
>
> * gnu/packages/video.scm (obs-vkcapture): New variable.
> ---
>  gnu/packages/video.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 60d39c38dc..62fea0d341 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -63,6 +63,7 @@
>  ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
>  ;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
>  ;;; Copyright © 2022 Andy Tai <atai@atai.org>
> +;;; Copyright © 2023 Ott Joon <oj@vern.cc>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3571,6 +3572,37 @@ (define-public obs-wlrobs
>  Wayland compositors.")
>      (license license:gpl3+)))
>  
> +(define-public obs-vkcapture
> +  (package
> +    (name "obs-vkcapture")
> +    (version "1.3.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/nowrep/obs-vkcapture")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "18v15bfzm31qkpwipvbqgzak4z6f2hhq6mnz2bvhwnv57whirln6"))))
> +    (build-system cmake-build-system)
> +    (arguments '(#:tests? #f))
> +    (native-inputs (list pkg-config))
> +    (inputs (list mesa
> +                  obs
> +                  libx11
> +                  libxcb
> +                  vulkan-headers
> +                  vulkan-loader
> +                  wayland))
> +    (home-page "https://github.com/nowrep/obs-vkcapture")
> +    (synopsis "OBS plugin for Vulkan/OpenGL game capture on Linux")
> +    (description "This OBS plugin lets you record an OpenGL or Vulkan
> +game by adding the Game Capture source to your scene and starting an
> +application with @code{obs-gamecapture}.")
> +    (license license:gpl2)))
> +
>  (define-public libvdpau
>    (package
>      (name "libvdpau")

Thank you for the patch!  I applied guix style to obs-vkcapture, added a
comment about tests and pushed as
14323edcc37d9efaae2491cf5f57ea0621412d7e.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 60d39c38dc..62fea0d341 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -63,6 +63,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
 ;;; Copyright © 2022 Andy Tai <atai@atai.org>
+;;; Copyright © 2023 Ott Joon <oj@vern.cc>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3571,6 +3572,37 @@  (define-public obs-wlrobs
 Wayland compositors.")
     (license license:gpl3+)))
 
+(define-public obs-vkcapture
+  (package
+    (name "obs-vkcapture")
+    (version "1.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nowrep/obs-vkcapture")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "18v15bfzm31qkpwipvbqgzak4z6f2hhq6mnz2bvhwnv57whirln6"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #f))
+    (native-inputs (list pkg-config))
+    (inputs (list mesa
+                  obs
+                  libx11
+                  libxcb
+                  vulkan-headers
+                  vulkan-loader
+                  wayland))
+    (home-page "https://github.com/nowrep/obs-vkcapture")
+    (synopsis "OBS plugin for Vulkan/OpenGL game capture on Linux")
+    (description "This OBS plugin lets you record an OpenGL or Vulkan
+game by adding the Game Capture source to your scene and starting an
+application with @code{obs-gamecapture}.")
+    (license license:gpl2)))
+
 (define-public libvdpau
   (package
     (name "libvdpau")