diff mbox series

[bug#73305,1/2] gnu: python-pycurl: Fix build by running the tests single-threaded.

Message ID f392dfea88bd56784b44ab3e9500e28b6d052877.1726520027.git.attila@lendvai.name
State New
Headers show
Series [bug#73305,1/2] gnu: python-pycurl: Fix build by running the tests single-threaded. | expand

Commit Message

Attila Lendvai Sept. 16, 2024, 8:53 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

* gnu/packages/python-web.scm (python-pycurl): Make test run single-threaded.
Reenable some tests that used to fail due to threading.
[test_request_without_certinfo]: Disable test/timebomb that probably uses an
expired CA.

Change-Id: I62bc60757cf2e005ed55768c84d8c178f63c35ec
---
 gnu/packages/python-web.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)


base-commit: 4f86fa20179ded1e6314eeba7da17309d501a32f
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8b29f1cd936..94e349bedb0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2024,15 +2024,18 @@  (define-public python-pycurl
     (build-system pyproject-build-system)
     (arguments
      '(#:test-flags
-       (list "-n" "auto"
+       (list
+        ;; The test suite is not thread safe:
+        ;; - some tests want to use the same port: address already in use
+        ;; - some tests use signal.Signal, i.e. main-thread only
+        "-n" "1"
              "-k" (string-append
                    ;; Disable hanginging tests
                    "not test_multi_socket_select"
                    ;; E assert None is not None
                    ;; E+ where None =
                    ;; <tests.multi_callback_test.MultiCallbackTest
-                   ;; testMethod=test_easy_pause_unpause>.socket_result
-                   " and not test_easy_pause_unpause"
+                   ;; testMethod=test_multi_socket_action>.timer_result
                    " and not test_multi_socket_action"
                    ;; E pycurl.error: (1, '')
                    " and not test_http_version_3"
@@ -2045,9 +2048,9 @@  (define-public python-pycurl
                    ;; OSError: tests/fake-curl/libcurl/with_openssl.so: cannot
                    ;; open shared object file: No such file or directory
                    " and not test_libcurl_ssl_openssl"
-                   ;; pycurl.error: (56, 'Recv failure: Connection reset by
-                   ;; peer')
-                   " and not test_post_with_read_callback"))
+                   ;; Probably due to an expired CA
+                   " and not test_request_without_certinfo"
+                   ))
        #:phases (modify-phases %standard-phases
                   (add-before 'build 'configure-tls-backend
                     (lambda _