diff mbox series

[bug#60563,1/1] gnu: nettle: Fix mingw cross-compilation.

Message ID f328720ab29bada6e9652684842074b47125c7e6.1672875360.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix mingw cross-compilation of nettle | expand

Commit Message

Vivien Kraus Jan. 4, 2023, 11:04 p.m. UTC
* gnu/packages/nettle.scm (nettle-2) [move-static-libraries]: .dll.a files are
not static libraries.
---
 gnu/packages/nettle.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Jan. 19, 2023, 4:31 p.m. UTC | #1
Hi Vivien,

Vivien Kraus <vivien@planete-kraus.eu> skribis:

> * gnu/packages/nettle.scm (nettle-2) [move-static-libraries]: .dll.a files are
> not static libraries.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 27bd9efc60..ea26ba3b2d 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -44,7 +44,7 @@  (define-public nettle-2
     (arguments
      ;; 'sexp-conv' and other programs need to have their RUNPATH point to
      ;; $libdir, which is not the case by default.  Work around it.
-     '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+     `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
                                               (assoc-ref %outputs "out")
                                               "/lib"))
        #:phases (modify-phases %standard-phases
@@ -59,7 +59,13 @@  (define-public nettle-2
                                       (rename-file ar (string-append
                                                        slib "/"
                                                        (basename ar))))
-                                    (find-files "." "\\.a$")))
+                                    (find-files
+                                     "."
+                                     ,(if (target-mingw?)
+                                          '(lambda (filename _)
+                                             (and (string-suffix? ".a" filename)
+                                                  (not (string-suffix? ".dll.a" filename))))
+                                          "\\.a$"))))
                         #t))))))
     (outputs '("out" "debug" "static"))
     (native-inputs (list m4))