diff mbox series

[bug#68742] gnu: river: add river.desktop on wayland-sessions

Message ID f2f2742f98cc9d7b54c371b5c7221d93ef0dcdf2.1706288949.git.eduarskate8@gmail.com
State New
Headers show
Series [bug#68742] gnu: river: add river.desktop on wayland-sessions | expand

Commit Message

Erik Eduardo Jan. 26, 2024, 5:09 p.m. UTC
From: Erik Eduardo <erikeah@protonmail.com>

This patch will allow to login from login managers or display managers
to River.

Changes:

  - Creates a directory at share named wayland-sessions
  - Install a desktop file from repo inside share/wayland-sessions

This is my first patch, please be patient and give me feedback, I will
do my best.

Change-Id: Iea8999cf97bedc8fb7ede4dd22b8f0f9529d2fa1
---
 gnu/packages/zig-xyz.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)


base-commit: 2266754382bce43789976aec65181cb5085c8bc4

Comments

Ekaitz Zarraga Jan. 29, 2024, 4:41 p.m. UTC | #1
Hi

On 2024-01-26 18:09, Erik Eduardo wrote:
> From: Erik Eduardo <erikeah@protonmail.com>
> 
> This patch will allow to login from login managers or display managers
> to River.
> 
> Changes:
> 
>    - Creates a directory at share named wayland-sessions
>    - Install a desktop file from repo inside share/wayland-sessions
> 
> This is my first patch, please be patient and give me feedback, I will
> do my best.
> 
> Change-Id: Iea8999cf97bedc8fb7ede4dd22b8f0f9529d2fa1
> ---
>   gnu/packages/zig-xyz.scm | 11 ++++++++++-
>   1 file changed, 10 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 200b5c9940..ca73c6bad8 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -52,7 +52,16 @@ (define-public river
>       (build-system zig-build-system)
>       (arguments
>        (list
> -      #:zig-build-flags #~(list "-Dxwayland")   ;experimental xwayland support
> +      #:phases #~(modify-phases %standard-phases
> +                   (add-after 'install 'install-extra-files
> +                     (lambda* (#:key outputs #:allow-other-keys)
> +                       (let* ((out (assoc-ref outputs "out"))
> +                              (wayland-sessions (string-append out
> +                                                 "/share/wayland-sessions")))
> +                         (mkdir-p wayland-sessions)
> +                         (install-file "contrib/river.desktop"
> +                                       wayland-sessions)))))
> +      #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
>         #:zig-release-type "safe"))
>       (native-inputs (list libevdev
>                            libxkbcommon
> 
> base-commit: 2266754382bce43789976aec65181cb5085c8bc4


Looks good to me, but guix commits follow changelog format:

https://www.gnu.org/prep/standards/standards.html#Change-Logs

The rest of it looks ok. Please resend with the message fixed and I'll 
take a further look.

Thanks a lot for contributing to Guix.

Ekaitz
Ekaitz Zarraga Feb. 14, 2024, 12:31 p.m. UTC | #2
user guix
usertag 68742 + reviewed-looks-good
thanks

Guix QA review form submission:
It's a simple addition. I think it's ok.
I linted, and I also built, and things the author expected work.

Items marked as checked: Lint warnings, Package builds, Commit messages
Christopher Baines Feb. 14, 2024, 1:33 p.m. UTC | #3
Ekaitz Zarraga <ekaitz@elenq.tech> writes:

> user guix
> usertag 68742 + reviewed-looks-good
> thanks
>
> Guix QA review form submission:
> It's a simple addition. I think it's ok.
> I linted, and I also built, and things the author expected work.
>
> Items marked as checked: Lint warnings, Package builds, Commit messages

Thanks both, I've tweaked the indentation a little and pushed this to
master as 8d4c3032416c69f883d074f4f6d7bcc9741be75c.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..ca73c6bad8 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -52,7 +52,16 @@  (define-public river
     (build-system zig-build-system)
     (arguments
      (list
-      #:zig-build-flags #~(list "-Dxwayland")   ;experimental xwayland support
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'install 'install-extra-files
+                     (lambda* (#:key outputs #:allow-other-keys)
+                       (let* ((out (assoc-ref outputs "out"))
+                              (wayland-sessions (string-append out
+                                                 "/share/wayland-sessions")))
+                         (mkdir-p wayland-sessions)
+                         (install-file "contrib/river.desktop"
+                                       wayland-sessions)))))
+      #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
       #:zig-release-type "safe"))
     (native-inputs (list libevdev
                          libxkbcommon