diff mbox series

[bug#70924,02/10] gnu: Add python-calver.

Message ID f2eb991e9c4bd9b90a2171f072b9cab251713894.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/python-build.scm (python-calver): New variable.

Change-Id: Icaf6d09519f792b42a5e0992b2e4fed4131b67f5
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 557c6d5815..901b0b25c5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25872,6 +25872,27 @@  (define-public python-send2trash
 user's @file{~/Trash} directory.")
     (license license:bsd-3)))
 
+(define-public python-calver
+  (package
+    (name "python-calver")
+    (version "2022.06.26")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/di/calver")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "14l9kv9igcmp5k6d2ahnx6z4dn6zy5kykz95hkh0rkqswn8x79b1"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pretend python-pytest))
+    (home-page "https://github.com/di/calver")
+    (synopsis "Setuptools extension for CalVer package versions")
+    (description "The calver package is a setuptools extension for
+automatically defining your Python package version as a calendar version.")
+    (license license:asl2.0)))
+
 (define-public python-pyfavicon
   (package
     (name "python-pyfavicon")