diff mbox series

[bug#69736,v2,5/6] gnu: Add python-cwltool.

Message ID f2d3c14ce1fc732f793e5adb5e6ede40a4fb099d.1720019008.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#69736,v2,1/6] gnu: Add python-pypubsub. | expand

Commit Message

Arun Isaac July 3, 2024, 3:07 p.m. UTC
* gnu/packages/bioinformatics.scm (python-cwltool): New variable.

Change-Id: Ic374d4c02b69c4e6c923d1cc17e629d4a3a6221c
---
 gnu/packages/bioinformatics.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 063017a8aa..b83e18ea78 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5816,6 +5816,18 @@  (define-public cwltool
 CWL descriptions.")
     (license license:asl2.0)))
 
+;; python-toil tightly integrates with cwltool using it as a library. So,
+;; create a library version of cwltool where inputs become propagated inputs.
+(define-public python-cwltool
+  (package
+    (inherit cwltool)
+    (name "python-cwltool")
+    (inputs
+     (list node))
+    (propagated-inputs
+     (modify-inputs (package-inputs cwltool)
+       (delete "node")))))
+
 (define-public python-dendropy
   (package
     (name "python-dendropy")