diff mbox series

[bug#70463] gnu: Add stb-image-resize.

Message ID f2ae89ce0c6d31f5803bc0c80f80cd3bcb68b51a.1713489293.git.aurtzy@gmail.com
State New
Headers show
Series [bug#70463] gnu: Add stb-image-resize. | expand

Commit Message

aurtzy April 19, 2024, 1:14 a.m. UTC
* gnu/packages/stb.scm (stb-image-resize): New variable.

Change-Id: Ia9d654277b26f1bce0f32d064a5d2ae6c434b677
---
 gnu/packages/stb.scm | 6 ++++++
 1 file changed, 6 insertions(+)


base-commit: 49f82fca4130ffcfb16aa0cf89750ab56fb99ad7
prerequisite-patch-id: f5e8f0d0088ee3f75f25a0a5c8516d21ff9f4ea1

Comments

John Kehayias April 19, 2024, 4:15 p.m. UTC | #1
Hello,

On Thu, Apr 18, 2024 at 09:14 PM, aurtzy wrote:

> * gnu/packages/stb.scm (stb-image-resize): New variable.
>
> Change-Id: Ia9d654277b26f1bce0f32d064a5d2ae6c434b677
> ---
>  gnu/packages/stb.scm | 6 ++++++
>  1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
> index 4ee1b4ebd2..9286bcd87d 100644
> --- a/gnu/packages/stb.scm
> +++ b/gnu/packages/stb.scm
> @@ -97,6 +97,12 @@ (define-public stb-image
>     "stb-image is a small and self-contained library for image loading or
>  decoding from file or memory.  A variety of formats are supported."))
>
> +(define-public stb-image-resize
> +  (make-stb-header-package
> +   "stb-image-resize" "0.96"
> +   "stb-image-resize is a library that supports scaling and translation of
> +images."))
> +
>  (define-public stb-image-write
>    (make-stb-header-package
>     "stb-image-write" "1.15"
>
> base-commit: 49f82fca4130ffcfb16aa0cf89750ab56fb99ad7
> prerequisite-patch-id: f5e8f0d0088ee3f75f25a0a5c8516d21ff9f4ea1

Thanks, pushed as ff692ed4cf!

John
diff mbox series

Patch

diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index 4ee1b4ebd2..9286bcd87d 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -97,6 +97,12 @@  (define-public stb-image
    "stb-image is a small and self-contained library for image loading or
 decoding from file or memory.  A variety of formats are supported."))
 
+(define-public stb-image-resize
+  (make-stb-header-package
+   "stb-image-resize" "0.96"
+   "stb-image-resize is a library that supports scaling and translation of
+images."))
+
 (define-public stb-image-write
   (make-stb-header-package
    "stb-image-write" "1.15"