diff mbox series

[bug#65644,gnome-team,v2,4/9] gnu: baobab: Update to 44.0.

Message ID f29be169fbd994b5e8a5f62e942e09e2847af745.1694031712.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#65644,gnome-team,v2,1/9] gnu: gcr: Update to 4.0.0. | expand

Commit Message

Liliana Marie Prikler Aug. 20, 2023, 7:01 a.m. UTC
* gnu/packages/gnome.scm (baobab): Update to 44.0.
[arguments]: Add ‘skip-gtk-update-icon-cache’ phase.
[native-inputs]: Remove gtk+:bin.
[inputs]: Remove libhandy.
---
 gnu/packages/gnome.scm | 20 ++++++++++++--------
 1 file changed, 12 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 90946716b3..557a22cad2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9693,7 +9693,7 @@  (define-public nautilus
 (define-public baobab
   (package
     (name "baobab")
-    (version "42.0")
+    (version "44.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -9702,24 +9702,28 @@  (define-public baobab
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1p2hg8qxbvdfax9z4qjhdsxia93zrsdq58krx8zjnn5ipbkan6jb"))))
+                "1h5zl7pvpp8yryi7j0cjzy1k89vlphdmfv0jr1l4bmr3j6xn6nw4"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t))
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson.build"
+               (("gtk_update_icon_cache: true")
+                "gtk_update_icon_cache: false")))))))
     (native-inputs
      (list desktop-file-utils           ;for update-desktop-database
            gettext-minimal
            `(,glib "bin")
-           `(,gtk+ "bin")               ;for gtk-update-icon-cache
            itstool
            libxml2
            pkg-config
            python
            vala))
-    (inputs
-     (list gtk
-           libadwaita
-           libhandy))
+    (inputs (list gtk libadwaita))
     (synopsis "Disk usage analyzer for GNOME")
     (description
      "Baobab (Disk Usage Analyzer) is a graphical application to analyse disk