diff mbox series

[bug#57368] gnu: Add python-plotext.

Message ID f28a1ac8e8ca1b7089446bc0aadb319b2d568bd2.1664220247.git.peter@polidoro.io
State New
Headers show
Series [bug#57368] gnu: Add python-plotext. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro Sept. 26, 2022, 7:25 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-plotext): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Vagrant Cascadian Sept. 2, 2023, 4:03 a.m. UTC | #1
On 2022-09-26, peter@polidoro.io wrote:
> * gnu/packages/python-xyz.scm (python-plotext): New variable.
...
> +(define-public python-plotext
> +  (package
> +    (name "python-plotext")
> +    (version "5.2.2")

A newer version was merged in:

eb2918aa96b74e45b35d18a209860f4a2d13ad68 gnu: Add python-plotext.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54ed7fefed..3ca1a8f24f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -745,6 +745,31 @@  (define-public python-pymdown-extensions
 Markdown.  All extensions are found under the module namespace of pymdownx.")
     (license license:expat)))
 
+(define-public python-plotext
+  (package
+    (name "python-plotext")
+    (version "5.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plotext" version))
+              (sha256
+               (base32
+                "1kxqvxkzlqh8pggfvinhs4g8727r792b1p4d894pj7a9b3jqhccq"))))
+    (build-system python-build-system)
+    ;; tests pass when run manually with test() function after install
+    ;; tests fail when run automatically during build with error:
+    ;; plotext: error: argument type: invalid choice: 'test'
+    (arguments
+     `(#:tests? #f))
+    (propagated-inputs (list python-pillow))
+    (home-page "https://github.com/piccolomo/plotext")
+    (synopsis "2D plotting library for Python to plot directly on a terminal")
+    (description
+     "Plotext is a Python 2D plotting library which produces
+figures directly on a terminal with syntax similar to matplotlib and can save
+plots as text or as colored html.")
+    (license license:expat)))
+
 (define-public python-plotille
   (package
     (name "python-plotille")